summaryrefslogtreecommitdiff
path: root/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2017-05-08 14:41:54 -0700
committerStefan Agner <stefan.agner@toradex.com>2017-05-12 13:54:18 -0700
commit6fcd37817cbea037bd1194b50382c7d8ca4b74ee (patch)
tree831d8933037194c97345cc0fce0301d52dd76a6f /examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
parent74e83463973d77b16449e7b9206f4f75b94296d1 (diff)
examples: convert CMake structure to allow multiple builds
Convert CMake build files structure such that we can build debug and release configuration simultaneously. This is useful when using Eclipse's Makefile integration. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Suggested-by: Raul Munoz <raul.munoz@toradex.com>
Diffstat (limited to 'examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt')
-rw-r--r--examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt b/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
index 7b23972..4fa749b 100644
--- a/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
+++ b/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
@@ -154,8 +154,7 @@ TARGET_LINK_LIBRARIES(hello_world nosys)
TARGET_LINK_LIBRARIES(hello_world -Wl,--end-group)
# MAP FILE
-SET(CMAKE_EXE_LINKER_FLAGS_DEBUG "${CMAKE_EXE_LINKER_FLAGS_DEBUG} -Xlinker -Map=debug/hello_world.map")
-SET(CMAKE_EXE_LINKER_FLAGS_RELEASE "${CMAKE_EXE_LINKER_FLAGS_RELEASE} -Xlinker -Map=release/hello_world.map")
+SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Xlinker -Map=hello_world.map")
# BIN AND HEX
ADD_CUSTOM_COMMAND(TARGET hello_world POST_BUILD COMMAND ${CMAKE_OBJCOPY} -Oihex ${EXECUTABLE_OUTPUT_PATH}/hello_world.elf ${EXECUTABLE_OUTPUT_PATH}/hello_world.hex)