summaryrefslogtreecommitdiff
path: root/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt')
-rw-r--r--examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt b/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
index 4fa749b..04a3bc2 100644
--- a/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
+++ b/examples/imx7_colibri_m4/demo_apps/hello_world/armgcc/CMakeLists.txt
@@ -22,10 +22,10 @@ SET(CMAKE_EXECUTABLE_LIBRARY_SUFFIX)
SET(ProjDirPath ${CMAKE_CURRENT_SOURCE_DIR})
# DEBUG LINK FILE
-set(CMAKE_EXE_LINKER_FLAGS_DEBUG "${CMAKE_EXE_LINKER_FLAGS_DEBUG} -T${ProjDirPath}/../../../../../platform/devices/MCIMX7D/linker/gcc/MCIMX7D_M4_tcm.ld -static")
+set(CMAKE_EXE_LINKER_FLAGS_DEBUG "${CMAKE_EXE_LINKER_FLAGS_DEBUG} -T MCIMX7D_M4_tcm.ld -static -L ${ProjDirPath}/../../../../../platform/devices/MCIMX7D/linker/gcc/")
# RELEASE LINK FILE
-set(CMAKE_EXE_LINKER_FLAGS_RELEASE "${CMAKE_EXE_LINKER_FLAGS_RELEASE} -T${ProjDirPath}/../../../../../platform/devices/MCIMX7D/linker/gcc/MCIMX7D_M4_tcm.ld -static")
+set(CMAKE_EXE_LINKER_FLAGS_RELEASE "${CMAKE_EXE_LINKER_FLAGS_RELEASE} -T MCIMX7D_M4_tcm.ld -static -L ${ProjDirPath}/../../../../../platform/devices/MCIMX7D/linker/gcc/")
# DEBUG ASM FLAGS
SET(CMAKE_ASM_FLAGS_DEBUG "${CMAKE_ASM_FLAGS_DEBUG} -g -mcpu=cortex-m4 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -mthumb -Wall -fno-common -ffunction-sections -fdata-sections -ffreestanding -fno-builtin -mapcs -std=gnu99")