summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-03-06 18:20:37 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-03-22 09:42:33 +0100
commitb6b6be765ba19454246a488f24873b9ef1f4cb78 (patch)
tree35d2350421072e7c596629df25f489bbf22c6a61
parent328a2ecefc5ffd6a15016500912877fd57f14441 (diff)
linux-firmware: rework additional package splitsmorty
The OE-Core layer backported some of the package splits to later versions of morty, resulting in a fatal QA error because this bbappend added the same packages. | ERROR: linux-firmware-1_0.0+gitAUTOINC+bf04291309-r0 do_package: QA Issue: linux-firmware-sd8887 is listed in PACKAGES multiple times, this leads to packaging errors. [packages-list] Convert this to some python magic to stay backward/forward compatible with any version of openembedded-core, morty branch. Reported-by: Jay Zhao Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-kernel/linux-firmware/linux-firmware_%.bbappend33
1 files changed, 15 insertions, 18 deletions
diff --git a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
index 12d95dc..372a43d 100644
--- a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
+++ b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
@@ -1,21 +1,18 @@
-#----------------------------------------------------------
-LICENSE_${PN}-rtl8188eu = "Firmware-rtlwifi_firmware"
+# Do this in python to stay backward/forward compatible with
+# openembedded-core, morty.
-PACKAGES_prepend = "\
- ${PN}-rtl8188eu \
- "
-FILES_${PN}-rtl8188eu = " \
- /lib/firmware/rtlwifi/rtl8188eufw.bin \
-"
-RDEPENDS_${PN}-rtl8188eu += "${PN}-rtl-license"
+python __anonymous () {
+ pks = (d.getVar("PACKAGES", False) or "").split()
-#----------------------------------------------------------
-LICENSE_${PN}-sd8887 = "Firmware-Marvell"
+ if ("${PN}-rtl8188eu" not in pks):
+ d.prependVar("PACKAGES", "${PN}-rtl8188eu ")
+ d.setVar("FILES_${PN}-rtl8188eu", "/lib/firmware/rtlwifi/rtl8188eufw.bin")
+ d.setVar("LICENSE_${PN}-rtl8188eu", "Firmware-rtlwifi_firmware")
+ d.appendVar("RDEPENDS_${PN}-rtl8188eu", " ${PN}-rtl-license")
-PACKAGES_prepend = "\
- ${PN}-sd8887 \
- "
-FILES_${PN}-sd8887 = " \
- /lib/firmware/mrvl/sd8887_uapsta.bin \
-"
-RDEPENDS_${PN}-sd8887 += "${PN}-marvell-license"
+ if ("${PN}-sd8887" not in pks):
+ d.prependVar("PACKAGES", "${PN}-sd8887 ")
+ d.setVar("FILES_${PN}-sd8887", "/lib/firmware/mrvl/sd8887_uapsta.bin")
+ d.setVar("LICENSE_${PN}-sd8887", "Firmware-Marvell")
+ d.appendVar("RDEPENDS_${PN}-sd8887", " ${PN}-marvell-license")
+}