summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-10-01 10:51:23 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-10-17 18:43:43 +0200
commit9174282925164acaa3c5cf9c45d1ff20c6a4d75c (patch)
tree468dcdad9dfc475f37bb800ac42422ab077e77bf
parent0dc8e4b651a9d777b330630f979128fc483753ea (diff)
linux-toradex-mainline: add preempt-rt configs as scc file
Change to add preempt-rt configs as scc file by including linux-imx.inc, also avoid setting KERNEL_FEATURES to empty, it could be used in torizoncore layer. Related-to: ELB-3171 Signed-off-by: Ming Liu <ming.liu@toradex.com> (cherry picked from commit 6737ce79c453953be6faf02519d9fc920dd58bb9)
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.cfg4
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.scc4
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline.inc11
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline_5.4.bb3
4 files changed, 12 insertions, 10 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.cfg b/recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.cfg
new file mode 100644
index 0000000..93e05af
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.cfg
@@ -0,0 +1,4 @@
+# CONFIG_PREEMPT_NONE is not set
+# CONFIG_PREEMPT_VOLUNTARY is not set
+# CONFIG_PREEMPT is not set
+CONFIG_PREEMPT_RT=y
diff --git a/recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.scc b/recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.scc
new file mode 100644
index 0000000..82d27dc
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-5.4/preempt-rt.scc
@@ -0,0 +1,4 @@
+define KFEATURE_DESCRIPTION "Enable Features needed by preempt-rt"
+define KFEATURE_COMPATIBILITY board
+
+kconf non-hardware preempt-rt.cfg
diff --git a/recipes-kernel/linux/linux-toradex-mainline.inc b/recipes-kernel/linux/linux-toradex-mainline.inc
index 18e87bb..31ccfe6 100644
--- a/recipes-kernel/linux/linux-toradex-mainline.inc
+++ b/recipes-kernel/linux/linux-toradex-mainline.inc
@@ -4,7 +4,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM ?= "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-inherit kernel toradex-kernel-config toradex-kernel-localversion
+inherit kernel-yocto kernel toradex-kernel-localversion
SRC_URI = " \
git://git.toradex.com/linux-toradex.git;protocol=https;branch=${KBRANCH};name=machine \
@@ -14,15 +14,6 @@ S = "${WORKDIR}/git"
DEPENDS += "coreutils-native lzop-native"
-kernel_do_configure_append_preempt-rt() {
- # switch to use PREEMPT_RT
- kernel_configure_variable PREEMPT_NONE n
- kernel_configure_variable PREEMPT_VOLUNTARY n
- kernel_configure_variable PREEMPT n
- kernel_configure_variable PREEMPT_RT y
- oe_runmake olddefconfig
-}
-
# Additional file deployed by recent mainline kernels
FILES_${KERNEL_PACKAGE_NAME}-base += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/modules.builtin.modinfo"
diff --git a/recipes-kernel/linux/linux-toradex-mainline_5.4.bb b/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
index 152b2db..e7eee62 100644
--- a/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline_5.4.bb
@@ -6,6 +6,8 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
SRCREV_machine = "26abb5b86e1735ed03660550a5e1a49e96554264"
SRCREV_machine_use-head-next = "${AUTOREV}"
+KCONFIG_MODE="--alldefconfig"
+
KBRANCH = "toradex_5.4.y"
require recipes-kernel/linux/linux-toradex-mainline.inc
@@ -16,6 +18,7 @@ SRC_URI += " \
SRC_URI_append_preempt-rt = " \
${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/older/patch-5.4.61-rt37.patch.xz;name=rt-patch \
+ file://preempt-rt.scc \
"
SRC_URI[rt-patch.md5sum] = "5a72e4f56ffdd79c8c668197f989f8d1"
SRC_URI[rt-patch.sha256sum] = "b2b52be0ef8b56a44a898ffc6a54515508e3cc9b2faece7a7d9f5d617a29ede1"