summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-04-05 15:08:52 +0200
committerMing Liu <ming.liu@toradex.com>2020-04-06 09:46:26 +0200
commitc61542ba4b1cf250459cc2e68e8739902492c613 (patch)
tree0e9a7e7b5e291c2231251ed0f20e12401cc24a8b
parente470126f2518f650c6bd3049d7143eb04c10db87 (diff)
u-boot-distro-boot: PROVIDES u-boot-default-script
A new virtual recipe u-boot-default-script has been introduced in meta-freescale-3rdparty and it's being included by WKS_FILE_DEPENDS, u-boot-distro-boot should PROVIDES it. Also change to deploy boot.scr-${MACHINE} instead of boot.scr, to be consistent with other u-boot-default-script recipes. Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index f7a5ae9..99d6b15 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -19,9 +19,11 @@ do_deploy() {
"${WORKDIR}/boot.cmd.in" > boot.cmd
mkimage -T script -C none -n "Distro boot script" -d boot.cmd boot.scr
- install -m 0644 boot.scr ${DEPLOYDIR}
+ install -m 0644 boot.scr ${DEPLOYDIR}/boot.scr-${MACHINE}
}
addtask deploy after do_install before do_build
+PROVIDES += "u-boot-default-script"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"