summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot/boot.cmd.in9
2 files changed, 6 insertions, 7 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index 4aa80fa..5f696df 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -9,6 +9,8 @@ SRC_URI = " \
file://boot.cmd.in \
"
+APPEND ?= ""
+
KERNEL_BOOTCMD ??= "bootz"
KERNEL_BOOTCMD:aarch64 ?= "booti"
@@ -17,7 +19,7 @@ DTB_PREFIX ??= "${@d.getVar('KERNEL_DTB_PREFIX').replace("/", "_") if d.getVar('
inherit deploy
do_deploy() {
- sed -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/;s/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/;s/@@KERNEL_DTB_PREFIX@@/${DTB_PREFIX}/' \
+ sed -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/;s/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/;s/@@KERNEL_DTB_PREFIX@@/${DTB_PREFIX}/;s/@@APPEND@@/${APPEND}/' \
"${WORKDIR}/boot.cmd.in" > boot.cmd
mkimage -T script -C none -n "Distro boot script" -d boot.cmd boot.scr
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot/boot.cmd.in b/recipes-bsp/u-boot/u-boot-distro-boot/boot.cmd.in
index 6969a55..9760ccc 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot/boot.cmd.in
+++ b/recipes-bsp/u-boot/u-boot-distro-boot/boot.cmd.in
@@ -67,11 +67,8 @@ if test "${root_devtype}" = ""; then
fi
fi
-if test -n ${setup}; then
- run setup
-else
- env set setupargs console=tty1 console=${console},${baudrate} consoleblank=0
-fi
+env set appendargs @@APPEND@@
+env set setupargs console=tty1 console=${console},${baudrate}
if test ${kernel_image} = "fitImage"; then
env set kernel_addr_load ${ramdisk_addr_r}
@@ -121,7 +118,7 @@ else
fi
fi
-env set bootcmd_args 'run rootfsargs_set && env set bootargs ${defargs} ${rootfsargs} ${setupargs} ${vidargs} ${tdxargs}'
+env set bootcmd_args 'run rootfsargs_set && env set bootargs ${rootfsargs} ${setupargs} ${appendargs} ${tdxargs}'
if test ${skip_fdt_overlays} != 1; then
env set bootcmd_overlays 'run load_overlays_file && run fdt_resize && run apply_overlays'
else