summaryrefslogtreecommitdiff
path: root/recipes-utils/xfsprogs/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-utils/xfsprogs/files')
-rw-r--r--recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch58
-rw-r--r--recipes-utils/xfsprogs/files/link_needed_libs.patch82
2 files changed, 0 insertions, 140 deletions
diff --git a/recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch b/recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch
deleted file mode 100644
index 951a144..0000000
--- a/recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 2b4714123cdecb558babb76074d0ab945bf5b177 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 16 Jun 2017 18:59:10 -0700
-Subject: [PATCH] define __ prefixed version of intXY_t types
-
-This is required since musl does not define them
-unlike glibc
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- include/linux.h | 29 +++++++++++++++++++++++++++++
- 1 file changed, 29 insertions(+)
-
-diff --git a/include/linux.h b/include/linux.h
-index 6a676ca..6976d83 100644
---- a/include/linux.h
-+++ b/include/linux.h
-@@ -40,6 +40,35 @@
- # undef fsxattr
- #endif
-
-+#ifndef loff_t
-+#define loff_t off_t
-+#endif
-+#ifndef __uint8_t
-+#define __uint8_t uint8_t
-+#endif
-+#ifndef __uint16_t
-+#define __uint16_t uint16_t
-+#endif
-+#ifndef __uint32_t
-+#define __uint32_t uint32_t
-+#endif
-+#ifndef __uint64_t
-+#define __uint64_t uint64_t
-+#endif
-+
-+#ifndef __int8_t
-+#define __int8_t int8_t
-+#endif
-+#ifndef __int16_t
-+#define __int16_t int16_t
-+#endif
-+#ifndef __int32_t
-+#define __int32_t int32_t
-+#endif
-+#ifndef __int64_t
-+#define __int64_t int64_t
-+#endif
-+
- static __inline__ int xfsctl(const char *path, int fd, int cmd, void *p)
- {
- return ioctl(fd, cmd, p);
---
-2.13.1
-
diff --git a/recipes-utils/xfsprogs/files/link_needed_libs.patch b/recipes-utils/xfsprogs/files/link_needed_libs.patch
deleted file mode 100644
index 1de634e..0000000
--- a/recipes-utils/xfsprogs/files/link_needed_libs.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-Index: xfsprogs-4.10.0/libxcmd/Makefile
-===================================================================
---- xfsprogs-4.10.0.orig/libxcmd/Makefile
-+++ xfsprogs-4.10.0/libxcmd/Makefile
-@@ -30,10 +30,21 @@ LCFLAGS += -DENABLE_EDITLINE
- LTLIBS += $(LIBEDITLINE) $(LIBTERMCAP)
- endif
-
-+ifeq ($(ENABLE_BLKID),yes)
-+LCFLAGS += -DENABLE_BLKID
-+LTLIBS += $(LIBBLKID)
-+endif
-+
-+LTLIBS += $(LIBXFS)
-+
- default: ltdepend $(LTLIBRARY)
-
- include $(BUILDRULES)
-
--install install-dev: default
-+install: default
-+ $(INSTALL_LTLIB)
-+
-+install-dev: default
-+ $(INSTALL_LTLIB_DEV)
-
- -include .ltdep
-Index: xfsprogs-4.10.0/libxfs/Makefile
-===================================================================
---- xfsprogs-4.10.0.orig/libxfs/Makefile
-+++ xfsprogs-4.10.0/libxfs/Makefile
-@@ -137,6 +137,7 @@ include $(BUILDRULES)
-
- install: default
- $(INSTALL) -m 755 -d $(PKG_INC_DIR)
-+ $(INSTALL_LTLIB)
-
- install-headers: $(addsuffix -hdrs, $(PKGHFILES))
-
-Index: xfsprogs-4.10.0/libxlog/Makefile
-===================================================================
---- xfsprogs-4.10.0.orig/libxlog/Makefile
-+++ xfsprogs-4.10.0/libxlog/Makefile
-@@ -19,6 +19,10 @@ default: ltdepend $(LTLIBRARY)
-
- include $(BUILDRULES)
-
--install install-dev: default
-+install: default
-+ $(INSTALL_LTLIB)
-+
-+install-dev: default
-+ $(INSTALL_LTLIB_DEV)
-
- -include .ltdep
-Index: xfsprogs-4.10.0/io/Makefile
-===================================================================
---- xfsprogs-4.10.0.orig/io/Makefile
-+++ xfsprogs-4.10.0/io/Makefile
-@@ -13,7 +13,7 @@
- getrusage.c imap.c link.c mmap.c open.c parent.c pread.c prealloc.c \
- pwrite.c reflink.c seek.c shutdown.c sync.c truncate.c utimes.c
-
--LLDLIBS = $(LIBXCMD) $(LIBHANDLE) $(LIBPTHREAD)
-+LLDLIBS = $(LIBXCMD) $(LIBHANDLE) $(LIBUUID) $(LIBPTHREAD)
- LTDEPENDENCIES = $(LIBXCMD) $(LIBHANDLE)
- LLDFLAGS = -static-libtool-libs
-
-Index: xfsprogs-4.10.0/quota/Makefile
-===================================================================
---- xfsprogs-4.10.0.orig/quota/Makefile
-+++ xfsprogs-4.10.0/quotq/Makefile
-@@ -14,7 +14,7 @@
- PCFILES = darwin.c freebsd.c irix.c linux.c
- LSRCFILES = $(shell echo $(PCFILES) | sed -e "s/$(PKG_PLATFORM).c//g")
-
--LLDLIBS = $(LIBXCMD)
-+LLDLIBS = $(LIBXCMD) $(LIBUUID)
- LTDEPENDENCIES = $(LIBXCMD)
- LLDFLAGS = -static
-
-