summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-11-15 14:15:25 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-11-16 09:44:02 +0100
commiteeaa1fa0f22496a84d42c2b54e4ae23b567b07f2 (patch)
tree64f963bf3257572dd1f036d627247f45f5199390
parentc369af47314e1b1e1776dcfa0cee1befc73fd044 (diff)
memtester backport version 4.5.1 from master
Changelog after 4.3.0: Version 4.5.1 30 May 2021 -documentation-only update. -add note to README about build problem with Tru64, with workaround. Thanks: VĂ­ctor Ostorga. Version 4.5.0 20 September 2020 -add note to README about problems with HP/UX prior to v.11. Change code so that buffer still gets aligned even if you comment out the use of mlock() on such a platform. Thanks: Keith Monahan. -fix clear-buffer using incorrect param, causing spurious test failures. Thanks: Debin Dong. -fix shell-ism in Makefile. Thanks: Fabrice Fontaine. Related-to: ELB-4232 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-benchmark/memtester/files/Makefile.patch28
-rw-r--r--recipes-benchmark/memtester/memtester_4.5.1.bb25
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-benchmark/memtester/files/Makefile.patch b/recipes-benchmark/memtester/files/Makefile.patch
new file mode 100644
index 0000000..971e52a
--- /dev/null
+++ b/recipes-benchmark/memtester/files/Makefile.patch
@@ -0,0 +1,28 @@
+From 9a950b14b9f7767d83e5faac2e1e8203c500e2c2 Mon Sep 17 00:00:00 2001
+From: Rod Whitby <rod@whitby.id.au>
+Date: Tue, 25 Oct 2011 18:43:50 -0500
+Subject: [PATCH] memtester: Added patch to Makefile to change no-longer-supported 'head -1' syntax to 'head -n 1'.
+
+Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
+---
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index a271bf5..6bccff3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,8 +32,8 @@ install: all
+ auto-ccld.sh: \
+ conf-cc conf-ld warn-auto.sh
+ ( cat warn-auto.sh; \
+- echo CC=\'`head -1 conf-cc`\'; \
+- echo LD=\'`head -1 conf-ld`\' \
++ echo CC=\'`head -n 1 conf-cc`\'; \
++ echo LD=\'`head -n 1 conf-ld`\' \
+ ) > auto-ccld.sh
+
+ compile: \
+--
+1.7.0.4
+
diff --git a/recipes-benchmark/memtester/memtester_4.5.1.bb b/recipes-benchmark/memtester/memtester_4.5.1.bb
new file mode 100644
index 0000000..1628a05
--- /dev/null
+++ b/recipes-benchmark/memtester/memtester_4.5.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Utility to test for faulty memory subsystem"
+HOMEPAGE = "http://pyropus.ca/software/memtester/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+SRC_URI = "http://pyropus.ca/software/memtester/old-versions/${BP}.tar.gz \
+ file://Makefile.patch \
+ "
+SRC_URI[md5sum] = "1bc22c01e987d6a67fac39dc5656a4d3"
+SRC_URI[sha256sum] = "1c5fc2382576c084b314cfd334d127a66c20bd63892cac9f445bc1d8b4ca5a47"
+
+do_compile () {
+ echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
+ echo '${CC} ${LDFLAGS}' > conf-ld
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man8
+ install -m 0755 memtester ${D}${bindir}/
+ install -m 0755 memtester.8 ${D}${mandir}/man8/
+}