summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Schenker <philippe.schenker@toradex.com>2020-05-15 17:18:55 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-01 10:54:25 +0200
commit019a0cbd01e59b8ae513988678d082c6d34b4b6e (patch)
treed16d239410679833cda709cdf2fc70bdc47ee8e1
parentdc60b4a47818c722acaf2fd8da62dd105d531d59 (diff)
recipes-connectivity: add hostapd-example package
This will add an example hostapd package that will contain all necessary files to just "enable" an acces-point on a demo image. Relates-to: ELB-1303 Signed-off-by: Philippe Schenker <philippe.schenker@toradex.com> (cherry picked from commit 7873d287300c204c594bc46429bca066cbd68bea)
-rw-r--r--recipes-connectivity/hostapd-example/hostapd-example.bb37
-rw-r--r--recipes-connectivity/hostapd-example/hostapd-example/enable-wifi.service13
-rw-r--r--recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.network5
-rw-r--r--recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.service12
-rw-r--r--recipes-connectivity/hostapd-example/hostapd-example/hostapd-tdx-demo-img.conf8
-rw-r--r--recipes-images/images/packagegroup-tdx-cli.bb1
6 files changed, 76 insertions, 0 deletions
diff --git a/recipes-connectivity/hostapd-example/hostapd-example.bb b/recipes-connectivity/hostapd-example/hostapd-example.bb
new file mode 100644
index 0000000..dc0b9db
--- /dev/null
+++ b/recipes-connectivity/hostapd-example/hostapd-example.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Deployment of example files to run hostapd on Toradex demo images"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+RDEPENDS_${PN} = "hostapd"
+
+S = "${WORKDIR}"
+
+SRC_URI = " \
+ file://enable-wifi.service \
+ file://hostapd-example.service \
+ file://hostapd-example.network \
+ file://hostapd-tdx-demo-img.conf \
+"
+
+inherit allarch systemd
+
+SYSTEMD_SERVICE_${PN} = "hostapd-example.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+do_install() {
+ install -d ${D}${systemd_unitdir}/system/ ${D}${systemd_unitdir}/network/ ${D}${sysconfdir}/
+ install -m 0644 enable-wifi.service ${D}${systemd_unitdir}/system/
+ install -m 0644 hostapd-example.network ${D}${systemd_unitdir}/network/
+ install -m 0644 hostapd-example.service ${D}${systemd_unitdir}/system/
+ install -m 0644 hostapd-tdx-demo-img.conf ${D}${sysconfdir}/
+ sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd-example.service
+}
+
+FILES_${PN} += " \
+ ${systemd_unitdir}/system/* \
+ ${systemd_unitdir}/network/hostapd-example.network \
+ ${sysconfdir}/hostapd-tdx-demo-img.conf \
+"
+
diff --git a/recipes-connectivity/hostapd-example/hostapd-example/enable-wifi.service b/recipes-connectivity/hostapd-example/hostapd-example/enable-wifi.service
new file mode 100644
index 0000000..623c281
--- /dev/null
+++ b/recipes-connectivity/hostapd-example/hostapd-example/enable-wifi.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Enable Wifi
+BindsTo=sys-subsystem-net-devices-uap0.device
+After=sys-subsystem-net-devices-uap0.device
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/connmanctl enable wifi
+ExecStop=
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.network b/recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.network
new file mode 100644
index 0000000..b498584
--- /dev/null
+++ b/recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.network
@@ -0,0 +1,5 @@
+[Match]
+Name=uap0
+[Network]
+Address=192.168.8.1/24
+DHCPServer=yes
diff --git a/recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.service b/recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.service
new file mode 100644
index 0000000..9f576ef
--- /dev/null
+++ b/recipes-connectivity/hostapd-example/hostapd-example/hostapd-example.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
+Requires=enable-wifi.service
+
+[Service]
+Type=forking
+PIDFile=/run/hostapd.pid
+ExecStart=@SBINDIR@/hostapd @SYSCONFDIR@/hostapd-tdx-demo-img.conf -P /run/hostapd.pid -B
+
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-connectivity/hostapd-example/hostapd-example/hostapd-tdx-demo-img.conf b/recipes-connectivity/hostapd-example/hostapd-example/hostapd-tdx-demo-img.conf
new file mode 100644
index 0000000..bc93609
--- /dev/null
+++ b/recipes-connectivity/hostapd-example/hostapd-example/hostapd-tdx-demo-img.conf
@@ -0,0 +1,8 @@
+interface=uap0
+ssid=testwifi
+hw_mode=a
+channel=40
+ieee80211n=1
+own_ip_addr=192.168.8.1
+wpa=2
+wpa_passphrase=testwifipw
diff --git a/recipes-images/images/packagegroup-tdx-cli.bb b/recipes-images/images/packagegroup-tdx-cli.bb
index 18a394b..cfcc5df 100644
--- a/recipes-images/images/packagegroup-tdx-cli.bb
+++ b/recipes-images/images/packagegroup-tdx-cli.bb
@@ -177,6 +177,7 @@ BACKPORTS = "backports"
RRECOMMENDS_packagegroup-wifi-tdx-cli = "\
${BACKPORTS} \
hostapd \
+ hostapd-example \
wireless-regdb-static \
"