summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-06-12 14:00:12 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-17 18:42:37 +0200
commit3e9e8f0f2fdee68f5bbc7066fb3302019bbcb309 (patch)
tree93ff8f74d110858c76fe86341208cf1a4626777b
parentde6f6e2d97cd9441a11b6343c8a34a96850dab42 (diff)
images: some cleaning up
- Drop LICENSE from graphical-tdx-image and verification-tdx-image, it's already defined in console-tdx-image recipe. - Drop deprecated variables ROOTFS_PKGMANAGE_PKGS, IMAGE_DEV_MANAGER, IMAGE_INIT_MANAGER, IMAGE_INITSCRIPTS, IMAGE_LOGIN_MANAGER. - timestamp-service is a systemd specific package, install it only for systemd distro. - Change udev-extra-rules to udev-extraconf, udev-extraconf is the new name after merging udev-extraconf and udev-extra-rules in OE: [ 0ca3a7823: udev-extraconf: Merge with udev-extra-rules from meta-oe ] Signed-off-by: Ming Liu <ming.liu@toradex.com> (cherry picked from commit 02531024c1bdcb64174ca75bfc674f3864361fd5)
-rw-r--r--recipes-images/images/console-tdx-image.bb13
-rw-r--r--recipes-images/images/graphical-tdx-image.bb2
-rw-r--r--recipes-images/images/verification-tdx-image.bb2
3 files changed, 2 insertions, 15 deletions
diff --git a/recipes-images/images/console-tdx-image.bb b/recipes-images/images/console-tdx-image.bb
index 9bbea51..3784272 100644
--- a/recipes-images/images/console-tdx-image.bb
+++ b/recipes-images/images/console-tdx-image.bb
@@ -25,9 +25,6 @@ ROOTFS_POSTPROCESS_COMMAND += " add_rootfs_version;"
IMAGE_LINGUAS = "en-us"
#IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
-#ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
-
-ROOTFS_PKGMANAGE_PKGS ?= '${@oe.utils.conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE}", d)}'
CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-client"
@@ -38,13 +35,7 @@ IMAGE_INSTALL += " \
packagegroup-machine-tdx-cli \
packagegroup-wifi-tdx-cli \
packagegroup-wifi-fw-tdx-cli \
- udev-extra-rules \
+ udev-extraconf \
${CONMANPKGS} \
- ${ROOTFS_PKGMANAGE_PKGS} \
- timestamp-service \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'timestamp-service', '', d)} \
"
-
-IMAGE_DEV_MANAGER = "udev"
-IMAGE_INIT_MANAGER = "systemd"
-IMAGE_INITSCRIPTS = " "
-IMAGE_LOGIN_MANAGER = "busybox shadow"
diff --git a/recipes-images/images/graphical-tdx-image.bb b/recipes-images/images/graphical-tdx-image.bb
index cdef167..3b101b7 100644
--- a/recipes-images/images/graphical-tdx-image.bb
+++ b/recipes-images/images/graphical-tdx-image.bb
@@ -3,8 +3,6 @@ require console-tdx-image.bb
SUMMARY = "Toradex Embedded Linux Graphical Image"
DESCRIPTION = "Image with a graphical interface, either using weston or X11"
-LICENSE = "MIT"
-
#Prefix to the resulting deployable tarball name
export IMAGE_BASENAME = "Graphical-Image"
diff --git a/recipes-images/images/verification-tdx-image.bb b/recipes-images/images/verification-tdx-image.bb
index 796184a..8c1a2a6 100644
--- a/recipes-images/images/verification-tdx-image.bb
+++ b/recipes-images/images/verification-tdx-image.bb
@@ -3,8 +3,6 @@ require graphical-tdx-image.bb
SUMMARY = "Toradex Embedded Linux Verification Image"
DESCRIPTION = "Image for BSP verification"
-LICENSE = "MIT"
-
#Prefix to the resulting deployable tarball name
export IMAGE_BASENAME = "Verification-Image"