summaryrefslogtreecommitdiff
path: root/recipes-images/images/tdx-updater_1.0.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-12-16 10:37:46 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 13:44:33 +0100
commitc73402f49cc0dd0e76cdea25db14ffebf3452104 (patch)
treec3ed70080b0d02e364a13940014df2cee31ad47f /recipes-images/images/tdx-updater_1.0.bb
parent4a9030893315b99967e83f06c815a5120101f44f (diff)
image-fstype: rework files installation
This adds a new recipe tdx-updater which provides the files needed by tdx-image-fstype.inc rather than copying them in a non OE way in tdx-image-fstype.inc. This required to restructure the layout in files. An additional update directory is inserted. Also in each of the overrides directories a symlink to library is created. This now allows to build legacy update images with a custom machine configuration if one adds the relevant machine override, e.g. for a machine targeting a colibri-imx6 module: MACHINEOVERRIDES .= ":colibri-imx6" Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-images/images/tdx-updater_1.0.bb')
-rw-r--r--recipes-images/images/tdx-updater_1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-images/images/tdx-updater_1.0.bb b/recipes-images/images/tdx-updater_1.0.bb
new file mode 100644
index 0000000..bee6a35
--- /dev/null
+++ b/recipes-images/images/tdx-updater_1.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Toradex legacy updater host files"
+DESCRIPTION = "Deploys files used by tdx-image-fstype.inc to create \
+the legacy update tarball."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://update file://library"
+
+do_install () {
+ install -d ${D}/${datadir}/update
+ cp -Lr ${WORKDIR}/update/* ${D}/${datadir}/update/
+}
+
+FILES_${PN} += "${datadir}/update"
+PACKAGE_ARCH = "${MACHINE_ARCH}"