summaryrefslogtreecommitdiff
path: root/recipes-devtools/mklibs/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/mklibs/files')
-rw-r--r--recipes-devtools/mklibs/files/ac_init_fix.patch19
-rw-r--r--recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch26
-rw-r--r--recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch43
3 files changed, 0 insertions, 88 deletions
diff --git a/recipes-devtools/mklibs/files/ac_init_fix.patch b/recipes-devtools/mklibs/files/ac_init_fix.patch
deleted file mode 100644
index 422af10..0000000
--- a/recipes-devtools/mklibs/files/ac_init_fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Get the version of mklibs by simpler means. The MKLIBS_VERSION string in the
-configure.ac file is replaced with real version string by the
-do_configure_prepend() function from the recipe .bb file.
-
-Upstream-Status: Inappropriate [configuration]
-
-Nitin A Kamble <nitin.a.kamble@intel.com>
-Date: 2011/01/24
-
-Index: mklibs/configure.ac
-===================================================================
---- mklibs.orig/configure.ac 2010-02-21 17:34:56.000000000 -0800
-+++ mklibs/configure.ac 2011-01-24 18:52:19.943242079 -0800
-@@ -1,4 +1,4 @@
--AC_INIT([mklibs],m4_esyscmd(dpkg-parsechangelog | perl -ne 'print $1 if m/^Version: (.*)$/;'))
-+AC_INIT([mklibs], MKLIBS_VERSION)
- AM_INIT_AUTOMAKE([foreign no-define])
- AC_CONFIG_HEADERS([config.h])
- AM_MAINTAINER_MODE
diff --git a/recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch b/recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch
deleted file mode 100644
index d27a489..0000000
--- a/recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-The libc6-dev in Ubuntu 9.04 is so old that the elf.h doesn't
-define STT_GNU_IFUNC, so we have to define it ourselves.
-
-Upstream-Status: Inappropriate [other] - old release specific, maybe removable
-
--- Dexuan Cui (dexuan.cui@intel.com) Feb 16, 2011.
-
-diff --git a/src/mklibs-readelf/main.cpp b/src/mklibs-readelf/main.cpp
-index 2444c39..56d93f8 100644
---- a/src/mklibs-readelf/main.cpp
-+++ b/src/mklibs-readelf/main.cpp
-@@ -6,6 +6,14 @@
- #include <vector>
-
- #include <elf.h>
-+/*
-+ * The /usr/include/elf.h in some distributions(like Ubuntu 9.04) doesn't
-+ * define the macro. We need to define it here.
-+ */
-+#ifndef STT_GNU_IFUNC
-+#define STT_GNU_IFUNC 10 /* Symbol is indirect code object */
-+#endif
-+
- #include <getopt.h>
-
- #include "elf.hpp"
diff --git a/recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch b/recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch
deleted file mode 100644
index baa12bd..0000000
--- a/recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-include <unistd.h> to fix build on gcc 4.7
-
-Many of the standard C++ library include files have been edited to no
-longer include <unistd.h> to remove namespace pollution in gcc 4.7, so
-we need include <unistd.h> manually sometimes.
-
-mklibs (0.1.33+nmu1) UNRELEASED; urgency=low
- * Non-maintainer upload
- * Fix FTBFS with gcc 4.7 due to missing <unistd.h> include (Closes: #667282).
-
--- Cyril Brulebois <kibi@debian.org> Thu, 05 Apr 2012 00:15:27 +0000
-
-mklibs (0.1.33) unstable; urgency=low
-
- * Adjust the libc_pic directory for multiarch as well.
-
-Upstream-Status: Backport
-
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-
-[Added upstream information about patch]
-
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
-
----
- src/mklibs-readelf/elf.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/mklibs-readelf/elf.cpp b/src/mklibs-readelf/elf.cpp
-index 444f330..654c46f 100644
---- a/src/mklibs-readelf/elf.cpp
-+++ b/src/mklibs-readelf/elf.cpp
-@@ -25,6 +25,7 @@
- #include <fcntl.h>
- #include <sys/mman.h>
- #include <sys/stat.h>
-+#include <unistd.h>
-
- using namespace Elf;
-
---
-1.7.10
-