summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Paulo Goncalves <joao.goncalves@toradex.com>2023-10-05 08:20:17 -0300
committerJoao Paulo Goncalves <joao.goncalves@toradex.com>2023-10-05 08:56:19 -0300
commitcaf5fc6d51833f41de44f195848ecaa096965e27 (patch)
tree01d984f34f16abd39469cfe11b849c6e0ca5a748
parent0dd8d488b694212cf02357c4651183938994e484 (diff)
u-boot: Add dtb deploy by configuration
To support multiple boot containers on imx8 modules and also device-tree environment for different u-boot configurations, there is a need to deploy the dtb by configuration. The old method of deploying is not removed for backward compatibility when using only one u-boot configuration. Related-to: TEI-1113 Signed-off-by: Joao Paulo Goncalves <joao.goncalves@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.04.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
index 517c061..c4579e1 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
@@ -37,6 +37,7 @@ do_deploy:append:mx8m-generic-bsp() {
then
install -d ${DEPLOYDIR}/${BOOT_TOOLS}
install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
+ install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}/${UBOOT_DTB_NAME}-${type}
install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
fi
done