summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-10-01 10:47:12 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-10-17 19:04:54 +0200
commit0ff302f214969262b093f862d1c579e570b93e28 (patch)
tree8eb59148768397c165902dddfd3492d5b98c7481
parent934f13d4bda72c88527a0ce642e9142f5493c676 (diff)
linux-toradex: add preempt-rt configs as scc file
Since now we are inheriting kernel-yocto.bbclass, let's change to add preempt-rt as scc file. Also avoid setting KERNEL_FEATURES to empty, it could be used in torizoncore layer. Related-to: ELB-3171 Signed-off-by: Ming Liu <ming.liu@toradex.com> (cherry picked from commit c37762740e37259e47269020bb8494f2325811bc)
-rw-r--r--recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg4
-rw-r--r--recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.scc4
-rw-r--r--recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb17
3 files changed, 9 insertions, 16 deletions
diff --git a/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg
new file mode 100644
index 0000000..93e05af
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.cfg
@@ -0,0 +1,4 @@
+# CONFIG_PREEMPT_NONE is not set
+# CONFIG_PREEMPT_VOLUNTARY is not set
+# CONFIG_PREEMPT is not set
+CONFIG_PREEMPT_RT=y
diff --git a/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.scc b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.scc
new file mode 100644
index 0000000..82d27dc
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-5.4-2.1.x/preempt-rt.scc
@@ -0,0 +1,4 @@
+define KFEATURE_DESCRIPTION "Enable Features needed by preempt-rt"
+define KFEATURE_COMPATIBILITY board
+
+kconf non-hardware preempt-rt.cfg
diff --git a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
index 06c3578..e8fcf95 100644
--- a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
+++ b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
@@ -1,13 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
require recipes-kernel/linux/linux-imx.inc
-python () {
- # Explicitly set KERNEL_FEATURES to empty, since we dont support KMETA yet.
- kernel_features = d.getVar('KERNEL_FEATURES')
- if kernel_features:
- d.setVar('KERNEL_FEATURES', '')
-}
-
SUMMARY = "Linux kernel for Toradex Freescale i.MX based modules"
SUMMARY_append_preempt-rt = "Real-Time Linux kernel for Toradex Freescale i.MX based modules"
@@ -51,6 +44,7 @@ KBUILD_DEFCONFIG_mx8 ?= "defconfig"
MIRRORS_append_preempt-rt = "${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/older/ ${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/"
SRC_URI_append_preempt-rt = " \
${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/older/patch-5.4.47-rt28.patch.xz;name=rt-patch \
+ file://preempt-rt.scc \
"
# This patches do currently not apply but are likely needed or we get
# runtime bugs.
@@ -60,12 +54,3 @@ SRC_URI_append_preempt-rt = " \
SRC_URI[rt-patch.md5sum] = "032a1eee60e746fe32a3aa73604bc3e4"
SRC_URI[rt-patch.sha256sum] = "dadc1379e816e8a23f09713884f8889f0177f291974487f33efc9a646082c562"
-
-kernel_do_configure_append_preempt-rt() {
- # switch to use PREEMPT_RT
- kernel_configure_variable PREEMPT_NONE n
- kernel_configure_variable PREEMPT_VOLUNTARY n
- kernel_configure_variable PREEMPT n
- kernel_configure_variable PREEMPT_RT y
- oe_runmake olddefconfig
-}