summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-10-17 16:50:53 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-10-18 10:43:07 +0200
commit130e47657f954098a38321ded0c4af9b840b9a49 (patch)
tree948fd4f64f98c5782be23626b5a47615a96336f6
parent74de15e0e00ebfdd9595563b9b37a8d6f1f43775 (diff)
imx-boot: fix overzealous new override syntax conversion
'compile_mx8m' is a variable name, not an override to the variable 'compile'. Fixes commit 6ea5ec9 ("layer: convert to new override syntax") Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_%.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
index a7b398c..8abacd9 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
+++ b/recipes-bsp/imx-mkimage/imx-boot_%.bbappend
@@ -1,8 +1,9 @@
# Create symbolic link rather than copying mkimage_uboot
-compile:mx8m:prepend() {
+compile_mx8m:prepend() {
rm -rf ${BOOT_STAGING}/mkimage_uboot
+# export LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE}:$LD_LIBRARY_PATH
}
-compile:mx8m:append() {
+compile_mx8m:append() {
rm -rf ${BOOT_STAGING}/mkimage_uboot
lnr ${STAGING_DIR_NATIVE}/${bindir}/mkimage ${BOOT_STAGING}/mkimage_uboot
}