summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-08-17 19:31:53 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-09-06 13:19:11 +0200
commit36ae1654b57f416627a2e56a3eb1e1c1a194d235 (patch)
tree84af14c56806f77e83f4b147e03d378bcfb6e62b
parent8e9bcd1a1ed4094877423dd4cbe967bea5b898fb (diff)
weston-init: customize
For upstream weston (i.e. not the imx fork) the following two settings are missing in the default weston.ini. Add them. - Set idle-time=0 to prevent weston from entering a screensaver mode on idle. - Set use-pixman=true for modules without a GPU to prevent weston from using a CPU to nearly 100% and having a very slow screen update rate, e.g. a not smoothly moving cursor. (downstream already has idle-time=0 set and performs well without use-pixman=true) Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 6d90430cc5a2691a81bb353c24b4d723f6784799)
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 1833c74..1ba5ed4 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -12,3 +12,38 @@ uncomment() {
sed -i -e 's,^#'"$1"','"$1"',g' $2
fi
}
+
+
+configure_noidle() {
+ sed -i '/idle-time=0/d' ${D}${sysconfdir}/xdg/weston/weston.ini
+ sed -i '/^\[core\]/a idle-time=0' ${D}${sysconfdir}/xdg/weston/weston.ini
+}
+
+# Prevent weston from going to sleep
+do_install:append:upstream() {
+ configure_noidle
+}
+
+configure_pixman() {
+ sed -i '/use-pixman=true/d' ${D}${sysconfdir}/xdg/weston/weston.ini
+ sed -i '/^\[core\]/a use-pixman=true' ${D}${sysconfdir}/xdg/weston/weston.ini
+}
+
+# With upstream weston and modules without GPU weston uses a lot of
+# cpu time and becomes very unresponsive. Setting use-pixman=true works
+# around it.
+do_install:append:upstream:colibri-imx6ull() {
+ configure_pixman
+}
+
+do_install:append:upstream:colibri-imx6ull-emmc() {
+ configure_pixman
+}
+
+do_install:append:upstream:colibri-imx7() {
+ configure_pixman
+}
+
+do_install:append:upstream:colibri-imx7-emmc() {
+ configure_pixman
+}