summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index d2eba90..d5f911a 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -47,3 +47,11 @@ do_install_append_upstream_colibri-imx7() {
do_install_append_upstream_colibri-imx7-emmc() {
configure_pixman
}
+
+# openembedded-core commit 4efdcc1090 ("weston: Use systemd notify,")
+# forces systemd-notify which in our setup does not work. Uncomment the
+# relevant lines for now.
+do_install_append() {
+ sed -i 's/\(Type=notify\)/# \1/' ${D}${systemd_system_unitdir}/weston@.service
+ sed -i 's/\(NotifyAccess=all\)/# \1/' ${D}${systemd_system_unitdir}/weston@.service
+}