summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex_2020.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2020.07.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
index f965e28..bc6405a 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2020.07.bb
@@ -31,6 +31,14 @@ nand_padding () {
dd bs=1024 count=1 if=/dev/zero | cat - ${PADDING_DIR}/u-boot.imx.zero-padded > ${PADDING_DIR}/u-boot-nand.imx
}
+deploy_uboot_with_spl () {
+ for config in ${UBOOT_MACHINE}; do
+ if [ -f "${B}/${config}/u-boot-with-spl.imx" ]; then
+ install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx
+ fi
+ done
+}
+
do_compile_append_colibri-imx6ull () {
nand_padding
}
@@ -42,3 +50,11 @@ do_compile_append_colibri-imx7 () {
do_compile_append_colibri-vf () {
nand_padding
}
+
+do_deploy_append_colibri-imx6 () {
+ deploy_uboot_with_spl
+}
+
+do_deploy_append_apalis-imx6 () {
+ deploy_uboot_with_spl
+}