summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-09-23 16:44:20 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 18:53:16 +0100
commit2bd3bdbbd65480ad6dbbc9e12957ba79f82f88ef (patch)
treed3bc2ecb02038f19fe5587c7a6eb2c988d57266b
parent78f06aa513802054ccabe10fca0cdbe2a5f6981d (diff)
xserver-xorg_1.17.4: explicitely include sysmacros.h
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch41
-rwxr-xr-xjetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb2
2 files changed, 43 insertions, 0 deletions
diff --git a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch
new file mode 100644
index 0000000..87a3112
--- /dev/null
+++ b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg/0001-sysmacros.h-follow-changed-include-files.patch
@@ -0,0 +1,41 @@
+From ee80095e03efcb6ff62983939c3f7c49c291f12e Mon Sep 17 00:00:00 2001
+From: Max Krummenacher <max.krummenacher@toradex.com>
+Date: Wed, 19 Sep 2018 20:37:47 +0000
+Subject: [PATCH] sysmacros.h: follow changed include files
+
+minor/major is no longer provided by sys/types.h.
+explicitely include sysmacros.h where needed.
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+---
+ hw/xfree86/common/xf86Xinput.c | 1 +
+ hw/xfree86/os-support/linux/lnx_init.c | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/hw/xfree86/common/xf86Xinput.c b/hw/xfree86/common/xf86Xinput.c
+index 1fb5b16..4fc5a65 100644
+--- a/hw/xfree86/common/xf86Xinput.c
++++ b/hw/xfree86/common/xf86Xinput.c
+@@ -82,6 +82,7 @@
+ #include <stdarg.h>
+ #include <stdint.h> /* for int64_t */
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #ifdef HAVE_SYS_MKDEV_H
+diff --git a/hw/xfree86/os-support/linux/lnx_init.c b/hw/xfree86/os-support/linux/lnx_init.c
+index 4acaf33..ceae0f1 100644
+--- a/hw/xfree86/os-support/linux/lnx_init.c
++++ b/hw/xfree86/os-support/linux/lnx_init.c
+@@ -37,6 +37,7 @@
+ #include "xf86_OSlib.h"
+
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+
+ #ifndef K_OFF
+ #define K_OFF 0x4
+--
+2.13.6
+
diff --git a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
index 9f5dbbf..06632b6 100755
--- a/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
+++ b/jetson-tk1/recipes-graphics/xorg-xserver/xserver-xorg_1.17.4.bb
@@ -3,6 +3,8 @@ require recipes-graphics/xorg-xserver/xserver-xorg.inc
SRC_URI[md5sum] = "1509a9daae713895e7f5bcba8bcc05b2"
SRC_URI[sha256sum] = "0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457"
+SRC_URI += "file://0001-sysmacros.h-follow-changed-include-files.patch"
+
# These extensions are now integrated into the server, so declare the migration
# path for in-place upgrades.