summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-12-02 15:12:04 +0000
committerStefan Agner <stefan.agner@toradex.com>2019-12-18 10:25:21 +0000
commitd92e9cac231e6737efbef067ac503e9e772ae29b (patch)
treeb25b405df07eb992fcf8649510294c5bf4164ffa
parent74ad3a824ec843f94b918dd7e5e39cbfa085a1c7 (diff)
linux-toradex: use new versioning
Use toradex-kernel-localversion class to implement the new versioning scheme for U-Boot. Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex_3.10.40.bb16
1 files changed, 1 insertions, 15 deletions
diff --git a/recipes-kernel/linux/linux-toradex_3.10.40.bb b/recipes-kernel/linux/linux-toradex_3.10.40.bb
index f5f1c0d..3438d7f 100644
--- a/recipes-kernel/linux/linux-toradex_3.10.40.bb
+++ b/recipes-kernel/linux/linux-toradex_3.10.40.bb
@@ -4,13 +4,10 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-inherit kernel siteinfo
+inherit kernel siteinfo toradex-kernel-localversion
LINUX_VERSION ?= "3.10.40"
-LOCALVERSION = "-${PR}"
-PR = "${TDX_VER_ITEM}"
-
SRCREV = "ad44961f8b3cf5ce342d234c7eca05d89369c26b"
SRCREV_use-head-next = "${AUTOREV}"
@@ -49,20 +46,9 @@ do_configure_prepend () {
#maybe change some configuration
config_script
- #Add Toradex BSP Version as LOCALVERSION
- sed -i -e /CONFIG_LOCALVERSION/d ${B}/.config
- echo "CONFIG_LOCALVERSION=\"${LOCALVERSION}\"" >> ${B}/.config
-
- #Add GIT revision to the local version
- head=`git --git-dir=${S}/.git rev-parse --verify --short HEAD 2> /dev/null`
- printf "%s%s" +g $head > ${S}/.scmversion
-
cd - > /dev/null
}
do_uboot_mkimage_prepend() {
cd ${B}
}
-
-# defaults
-TDX_VER_ITEM ??= "0"