summaryrefslogtreecommitdiff
path: root/recipes-devtools/python/python/dont_build_tkinter.patch
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-01-05 11:12:16 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2016-03-14 16:53:18 +0100
commit8a158e272efb2ba4290c90b119519953a6d88112 (patch)
tree09690060cb2a89d98b7a359838fc98473bc40163 /recipes-devtools/python/python/dont_build_tkinter.patch
parent1c8332215a6dd8a9f59818c60e343bd2298a885b (diff)
python: add a PACKAGECONFIG for _tkinter
Currently _tkinter is only built when tcl/tk is available before the python do_configure task is built. Make this deterministic by providing a PACKAGECONFIG for it. If tkinter is in PACKAGECONFIG add the needed dependencies, if not force that tkinter is not built. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-devtools/python/python/dont_build_tkinter.patch')
-rw-r--r--recipes-devtools/python/python/dont_build_tkinter.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-devtools/python/python/dont_build_tkinter.patch b/recipes-devtools/python/python/dont_build_tkinter.patch
new file mode 100644
index 0000000..bdd47a8
--- /dev/null
+++ b/recipes-devtools/python/python/dont_build_tkinter.patch
@@ -0,0 +1,24 @@
+_tkinter module needs tk module along with tcl.
+Force python to not be built with _tkinter.
+
+Upstream-Status: Inappropriate [distribution]
+
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+
+--- Python-2.7.9/setup.py.orig 2015-12-20 16:56:24.580951972 +0100
++++ Python-2.7.9/setup.py 2015-12-20 17:00:34.524083526 +0100
+@@ -1762,10 +1762,11 @@
+ self.extensions.extend(exts)
+
+ # Call the method for detecting whether _tkinter can be compiled
+- self.detect_tkinter(inc_dirs, lib_dirs)
++ # disable detection of tcl/tk and thus don't build python with _tkinter
++ #self.detect_tkinter(inc_dirs, lib_dirs)
+
+- if '_tkinter' not in [e.name for e in self.extensions]:
+- missing.append('_tkinter')
++ #if '_tkinter' not in [e.name for e in self.extensions]:
++ # missing.append('_tkinter')
+
+ ## # Uncomment these lines if you want to play with xxmodule.c
+ ## ext = Extension('xx', ['xxmodule.c'])