summaryrefslogtreecommitdiff
path: root/recipes-core/util-linux/util-linux_%.bbappend
diff options
context:
space:
mode:
authorDenys Drozdov <denys.drozdov@toradex.com>2021-07-21 18:16:33 +0300
committerDenys Drozdov <denys.drozdov@toradex.com>2021-07-22 11:08:10 +0300
commit4ecee0bd7785f3132c85a1de2ef7ab6e7da955c2 (patch)
tree87ea5610941c9987dce88230917bc5becac89067 /recipes-core/util-linux/util-linux_%.bbappend
parentf086646d01378903661c5ac8d1925dc855540040 (diff)
util-linux: add separate bbappend to support fstrim service
fstrim.service is disabled by default in openembedded-core layer. Add bbappend file to support fstrim.service for systemd Related-to: ELB-2356 Signed-off-by: Denys Drozdov <denys.drozdov@toradex.com>
Diffstat (limited to 'recipes-core/util-linux/util-linux_%.bbappend')
-rw-r--r--recipes-core/util-linux/util-linux_%.bbappend18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-core/util-linux/util-linux_%.bbappend b/recipes-core/util-linux/util-linux_%.bbappend
new file mode 100644
index 0000000..341efcf
--- /dev/null
+++ b/recipes-core/util-linux/util-linux_%.bbappend
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI_append_ = " file://fstrim.service file://fstrim.timer"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "fstrim.service fstrim.timer"
+SYSTEMD_AUTO_ENABLE = "disable"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/fstrim.service ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/fstrim.timer ${D}${systemd_unitdir}/system/
+ sed -i -e 's,@SBINDIR@,${sbindir},g' \
+ -e 's,@SYSCONFDIR@,${sysconfdir},g' \
+ ${D}${systemd_unitdir}/system/*.service
+}
+