summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot-mainline/files/0007-imx-fix-building-for-i.mx8-without-spl.patch
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-13 14:52:49 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-13 19:32:22 +0200
commit258adbe3d2ac9c7c8d31e5071c0689a4227dae09 (patch)
tree79c9c1168904b56bc9a1611f39ff31c3aefe4795 /recipes-bsp/u-boot-mainline/files/0007-imx-fix-building-for-i.mx8-without-spl.patch
parentdc4a695bba8f4becb8b821515e16079453ccd135 (diff)
u-boot: provide a mainline u-boot, based on 2019.07 rc1
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot-mainline/files/0007-imx-fix-building-for-i.mx8-without-spl.patch')
-rw-r--r--recipes-bsp/u-boot-mainline/files/0007-imx-fix-building-for-i.mx8-without-spl.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot-mainline/files/0007-imx-fix-building-for-i.mx8-without-spl.patch b/recipes-bsp/u-boot-mainline/files/0007-imx-fix-building-for-i.mx8-without-spl.patch
new file mode 100644
index 0000000..b4ebfad
--- /dev/null
+++ b/recipes-bsp/u-boot-mainline/files/0007-imx-fix-building-for-i.mx8-without-spl.patch
@@ -0,0 +1,37 @@
+From 961ca9ed15a4f2c1f590f4dc02f69b93c773a90f Mon Sep 17 00:00:00 2001
+From: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+Date: Fri, 26 Apr 2019 10:56:13 +0200
+Subject: [PATCH 07/19] imx: fix building for i.mx8 without spl
+
+Building with Travis CI complained and stopped with the following error:
++cc1: fatal error: opening output file spl/u-boot-spl.cfgout: No such
+file or directory
++compilation terminated.
+
+This fixes commit caceb739ea07 ("imx: build flash.bin for i.MX8") which
+took SPL being enabled on i.MX8 for granted.
+
+Reported-by: Stefano Babic <sbabic@denx.de>
+Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
+Reviewed-by: Peng Fan <peng.fan@nxp.com>
+---
+ arch/arm/mach-imx/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/arm/mach-imx/Makefile b/arch/arm/mach-imx/Makefile
+index 37675d0558..6531c67fc6 100644
+--- a/arch/arm/mach-imx/Makefile
++++ b/arch/arm/mach-imx/Makefile
+@@ -107,7 +107,9 @@ IMX_CONFIG = $(CONFIG_IMX_CONFIG:"%"=%)
+ ifeq ($(CONFIG_ARCH_IMX8), y)
+ CNTR_DEPFILES := $(srctree)/tools/imx_cntr_image.sh
+ IMAGE_TYPE := imx8image
++ifeq ($(CONFIG_SPL_BUILD),y)
+ SPL_DEPFILE_EXISTS := $(shell $(CPP) $(cpp_flags) -x c -o spl/u-boot-spl.cfgout $(srctree)/$(IMX_CONFIG); if [ -f spl/u-boot-spl.cfgout ]; then $(CNTR_DEPFILES) spl/u-boot-spl.cfgout; echo $$?; fi)
++endif
+ DEPFILE_EXISTS := $(shell $(CPP) $(cpp_flags) -x c -o u-boot-dtb.cfgout $(srctree)/$(IMX_CONFIG); if [ -f u-boot-dtb.cfgout ]; then $(CNTR_DEPFILES) u-boot-dtb.cfgout; echo $$?; fi)
+ else ifeq ($(CONFIG_ARCH_IMX8M), y)
+ IMAGE_TYPE := imx8mimage
+--
+2.14.5
+