summaryrefslogtreecommitdiff
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/formfactor/formfactor/colibri-imx7/machconfig0
-rw-r--r--recipes-bsp/formfactor/formfactor_%.bbappend1
-rw-r--r--recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.16.0.bb (renamed from recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.15.0.bb)8
-rw-r--r--recipes-bsp/isp-imx/isp-imx/0001-isp-imx-start_isp-don-t-report-error-if-no-camera-is.patch1
-rw-r--r--recipes-bsp/u-boot/files/0001-Revert-apalis-imx8-fused-modules-boot-from-emmc.patch31
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.04.bb50
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2024.04.bb28
7 files changed, 35 insertions, 84 deletions
diff --git a/recipes-bsp/formfactor/formfactor/colibri-imx7/machconfig b/recipes-bsp/formfactor/formfactor/colibri-imx7/machconfig
deleted file mode 100644
index e69de29..0000000
--- a/recipes-bsp/formfactor/formfactor/colibri-imx7/machconfig
+++ /dev/null
diff --git a/recipes-bsp/formfactor/formfactor_%.bbappend b/recipes-bsp/formfactor/formfactor_%.bbappend
deleted file mode 100644
index 4fc41d0..0000000
--- a/recipes-bsp/formfactor/formfactor_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.15.0.bb b/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.16.0.bb
index 1e21434..3cd2937 100644
--- a/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.15.0.bb
+++ b/recipes-bsp/imx-sc-firmware/imx-sc-firmware-toradex_1.16.0.bb
@@ -4,14 +4,18 @@
DESCRIPTION = "i.MX System Controller Firmware for Toradex hardware"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
+LIC_FILES_CHKSUM = "file://COPYING;md5=10c0fda810c63b052409b15a5445671a"
+FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V56 = "10c0fda810c63b052409b15a5445671a"
+FSL_EULA_FILE_MD5SUMS:append = " \
+ ${FSL_EULA_FILE_MD5SUM_LA_OPT_NXP_SOFTWARE_LICENSE_V56} \
+"
SECTION = "BSP"
inherit deploy
SRC_URI = "git://github.com/toradex/i.MX-System-Controller-Firmware.git;branch=master;protocol=https;fsl-eula=true"
-SRCREV = "7b7c7f7c834c58e637a53bab281d48f963788e33"
+SRCREV = "bc23c64b45a2d23cfcc2fa5e4951786934db583e"
SRCREV:use-head-next = "${AUTOREV}"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-start_isp-don-t-report-error-if-no-camera-is.patch b/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-start_isp-don-t-report-error-if-no-camera-is.patch
index 2adcf8e..2d38ede 100644
--- a/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-start_isp-don-t-report-error-if-no-camera-is.patch
+++ b/recipes-bsp/isp-imx/isp-imx/0001-isp-imx-start_isp-don-t-report-error-if-no-camera-is.patch
@@ -10,6 +10,7 @@ goes to the failed state.
Return '0' in that case as obviously the device tree doesn't have a
camera configured and the service is not needed.
+Upstream-Status: Pending
Related-to: ELB-5002
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
---
diff --git a/recipes-bsp/u-boot/files/0001-Revert-apalis-imx8-fused-modules-boot-from-emmc.patch b/recipes-bsp/u-boot/files/0001-Revert-apalis-imx8-fused-modules-boot-from-emmc.patch
deleted file mode 100644
index fdf009e..0000000
--- a/recipes-bsp/u-boot/files/0001-Revert-apalis-imx8-fused-modules-boot-from-emmc.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 7ade24bca52e1e6517ae9eb6c2820a0c7e881acd Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Tue, 28 May 2019 12:56:37 +0200
-Subject: [PATCH] Revert "apalis-imx8: fused modules boot from emmc"
-
-If one wants to build for Apalis iMX8 QM V1.0A one wants to boot the image
-from SD card.
-
-This reverts commit c3d2ea3ea8a0c090cf359f286739f31d681ef71e.
----
- include/configs/apalis-imx8.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/configs/apalis-imx8.h b/include/configs/apalis-imx8.h
-index ace5f172bd..f9b254fae0 100644
---- a/include/configs/apalis-imx8.h
-+++ b/include/configs/apalis-imx8.h
-@@ -198,8 +198,8 @@
- #define CONFIG_SYS_MMC_IMG_LOAD_PART 1
-
- /* On Apalis iMX8 USDHC1 is eMMC, USDHC2 is 8-bit SD and USDHC3 is 4-bit SD */
--#define CONFIG_SYS_MMC_ENV_DEV 0 /* USDHC1 eMMC */
--#define CONFIG_MMCROOT "/dev/mmcblk0p2" /* USDHC1 eMMC */
-+#define CONFIG_SYS_MMC_ENV_DEV 1 /* USDHC1 eMMC */
-+#define CONFIG_MMCROOT "/dev/mmcblk1p2" /* USDHC1 eMMC */
- #define CONFIG_SYS_FSL_USDHC_NUM 3
-
- #define CONFIG_SYS_BOOTM_LEN (64 << 20) /* Increase max gunzip size */
---
-2.13.6
-
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
deleted file mode 100644
index 90b706c..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-SUMMARY = "U-Boot bootloader with support for Toradex i.MX 8 series SoMs"
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-LICENSE = "GPL-2.0-or-later"
-LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "bc-native dtc-native flex-native bison-native python3-setuptools-native"
-PROVIDES:append = " u-boot"
-
-require recipes-bsp/u-boot/u-boot.inc
-
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-SRCREV = "3428b470191ca0f5bb48d95e77e8ba48d9708a42"
-SRCREV:use-head-next = "${AUTOREV}"
-SRCBRANCH = "toradex_imx_lf_v2022.04"
-
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
-BOOT_TOOLS = "imx-boot-tools"
-
-inherit toradex-u-boot-localversion
-# build imx-boot from within U-Boot
-inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
-
-UBOOT_INITIAL_ENV = "u-boot-initial-env"
-
-COMPATIBLE_MACHINE = "(mx8-generic-bsp)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-do_deploy:append:mx8m-generic-bsp() {
- # Deploy the u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
- if [ -n "${UBOOT_CONFIG}" ]
- then
- for config in ${UBOOT_MACHINE}; do
- i=$(expr $i + 1);
- for type in ${UBOOT_CONFIG}; do
- j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
- install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}/${UBOOT_DTB_NAME}-${type}
- install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
- fi
- done
- unset j
- done
- unset i
- fi
-}
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2024.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2024.04.bb
new file mode 100644
index 0000000..d68cd7b
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex_2024.04.bb
@@ -0,0 +1,28 @@
+SUMMARY = "U-Boot bootloader with support for Toradex i.MX 8 series SoMs"
+HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
+SECTION = "bootloaders"
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "bc-native dtc-native flex-native bison-native python3-setuptools-native"
+PROVIDES:append = " u-boot"
+
+require recipes-bsp/u-boot/u-boot.inc
+
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
+SRCREV = "22d100d163d841f261eecd76e01025b9782f6378"
+SRCREV:use-head-next = "${AUTOREV}"
+SRCBRANCH = "toradex_imx_lf_v2024.04"
+
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+BOOT_TOOLS = "imx-boot-tools"
+
+inherit toradex-u-boot-localversion
+# build imx-boot from within U-Boot
+inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
+
+UBOOT_INITIAL_ENV = "u-boot-initial-env"
+
+COMPATIBLE_MACHINE = "(colibri-imx8x|apalis-imx8)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"