summaryrefslogtreecommitdiff
path: root/recipes-core/udev/udev-toradex-rules.bb
diff options
context:
space:
mode:
authorPhilippe Schenker <philippe.schenker@toradex.com>2020-03-13 20:20:14 +0100
committerStefan Agner <stefan.agner@toradex.com>2020-03-19 16:00:23 +0000
commit492fb93221f032c4d1450ec62002b4e11e832cac (patch)
treeeda3f47e495109b09cc5f84f0c0cb13f577b1727 /recipes-core/udev/udev-toradex-rules.bb
parent32e6c85e8795dce3a654325fdbfb2946de891033 (diff)
recipes-core: Add udev-toradex-rules recipe
These rules make sure that a symlink is created for all i2c and tty devices. This symlinks are named like on the Toradex carrier boards. This makes it easy to identify which device in software is matching the hardware pins. Additional non-standard devices that are not named clearly on the carrier board are left out to prevent confusion. Related-to: ELB-2380 Signed-off-by: Philippe Schenker <philippe.schenker@toradex.com> (cherry picked from commit 47ef64803548f73a0eda753c5d3d3f7f315af606)
Diffstat (limited to 'recipes-core/udev/udev-toradex-rules.bb')
-rw-r--r--recipes-core/udev/udev-toradex-rules.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-core/udev/udev-toradex-rules.bb b/recipes-core/udev/udev-toradex-rules.bb
new file mode 100644
index 0000000..9cc69a9
--- /dev/null
+++ b/recipes-core/udev/udev-toradex-rules.bb
@@ -0,0 +1,11 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "\
+ file://99-toradex.rules \
+"
+
+do_install () {
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/99-toradex.rules ${D}${sysconfdir}/udev/rules.d/
+}