summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 11:39:39 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 17:30:38 +0200
commitf14b98b99ce1ddc6bdd6a1a9e6e017705054d8d9 (patch)
tree01869777f71a9234b4bacf9a465e0e41b7af5885 /recipes-kernel/linux-firmware/linux-firmware_%.bbappend
parent510e0843925dd5f7a6d5c1d8190653ae17c3dd2a (diff)
linux-firmware: cope with moved directory for unpackHEADmaster
OE master (styhead) no longer unpacks in ${WORKDIR} but rather does it in path defined by the new variable UNPACKDIR. A directory created under UNPACKDIR which matches the setting of ${S} is then moved to ${S}. If ${S} already exist the move will create an additional subdirectory rather than creating ${S} with the expected content. Change the recipe so that ${S} does not already exist from the git checkout of imx-firmware and thus have the files from linux-firmware*tar where they are expected. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel/linux-firmware/linux-firmware_%.bbappend')
-rw-r--r--recipes-kernel/linux-firmware/linux-firmware_%.bbappend8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
index 6bfd97e..6c4b2ec 100644
--- a/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
+++ b/recipes-kernel/linux-firmware/linux-firmware_%.bbappend
@@ -1,13 +1,17 @@
IMX_FIRMWARE_SRC ?= "git://github.com/NXP/imx-firmware.git;protocol=https"
SRCBRANCH_imx-firmware = "lf-6.6.3_1.0.0"
SRC_URI += " \
- ${IMX_FIRMWARE_SRC};branch=${SRCBRANCH_imx-firmware};destsuffix=${S}/imx-firmware;name=imx-firmware \
+ ${IMX_FIRMWARE_SRC};branch=${SRCBRANCH_imx-firmware};destsuffix=${WORKDIR}/imx-firmware;name=imx-firmware \
"
SRCREV_imx-firmware = "2afa15e77f0b58eade42b4f59c9215339efcca66"
SRCREV_FORMAT = "default_imx-firmware"
+do_compile:prepend () {
+ mv ${WORKDIR}/imx-firmware ${S}
+}
+
do_install:append () {
# Install IMX Firmware EULA/LICENSE license
install -d ${D}${nonarch_base_libdir}/firmware
@@ -35,7 +39,7 @@ LICENSE += " \
& firmware-imx \
"
LIC_FILES_CHKSUM += " \
- file://imx-firmware/LICENSE.txt;md5=44a8052c384584ba09077e85a3d1654f \
+ file://${WORKDIR}/imx-firmware/LICENSE.txt;md5=44a8052c384584ba09077e85a3d1654f \
"
NO_GENERIC_LICENSE[firmware-imx] = "imx-firmware/LICENSE.txt"