summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-distro-boot.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-distro-boot.bb b/recipes-bsp/u-boot/u-boot-distro-boot.bb
index f7a5ae9..99d6b15 100644
--- a/recipes-bsp/u-boot/u-boot-distro-boot.bb
+++ b/recipes-bsp/u-boot/u-boot-distro-boot.bb
@@ -19,9 +19,11 @@ do_deploy() {
"${WORKDIR}/boot.cmd.in" > boot.cmd
mkimage -T script -C none -n "Distro boot script" -d boot.cmd boot.scr
- install -m 0644 boot.scr ${DEPLOYDIR}
+ install -m 0644 boot.scr ${DEPLOYDIR}/boot.scr-${MACHINE}
}
addtask deploy after do_install before do_build
+PROVIDES += "u-boot-default-script"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"