summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-08-01 15:27:21 +0200
committerMing Liu <ming.liu@toradex.com>2022-08-06 18:40:42 +0200
commit803e966c7f9f276fb5a0e36fdfe1542f63e29604 (patch)
tree29c165b8e325889f0484783817138479c2a7cf3b
parentff29f4ef087da0d960ba7c778764e53c70f2e124 (diff)
gpio-tool: inherit bin_package
gpio-tool supposes to be a bin package, let it behave so by inheriting bin_package.bbclass. Also add glib-2.0 to DEPENDS, the binary gpio-tool is linking to it. Related-to: ELB-4471 Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-support/gpio-tool/gpio-tool.bb12
1 files changed, 2 insertions, 10 deletions
diff --git a/recipes-support/gpio-tool/gpio-tool.bb b/recipes-support/gpio-tool/gpio-tool.bb
index 9ee6029..45181a8 100644
--- a/recipes-support/gpio-tool/gpio-tool.bb
+++ b/recipes-support/gpio-tool/gpio-tool.bb
@@ -5,7 +5,7 @@ PR = "r3"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-DEPENDS = "gtk+"
+DEPENDS = "glib-2.0 gtk+"
SRC_URI = " \
file://gpio-tool \
@@ -13,17 +13,13 @@ SRC_URI = " \
file://gpio-tool.png \
"
-PACKAGES = "${PN}"
+inherit bin_package
#no gnu_hash in binaries, skip QA dev-so for this package
#we have symlinks ending in .so, skip QA ldflags for this package
#inhibit warnings about files being stripped
INSANE_SKIP:${PN} = "ldflags already-stripped"
-# just don't do any configuring
-do_configure() {
-}
-
do_install() {
install -d ${D}/${bindir}
install -d ${D}/${datadir}/applications
@@ -34,7 +30,3 @@ do_install() {
install -m 644 ${WORKDIR}/gpio-tool.png ${D}/${datadir}/pixmaps/
ln -s ${datadir}/applications/gpio-tool.desktop ${D}/home/root/Desktop/
}
-
-FILES:${PN} += " \
- /home/root/Desktop \
-"