summaryrefslogtreecommitdiff
path: root/recipes-core/systemd
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-08-08 11:11:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:18:40 +0200
commite7f6f37cdbc8ba971a151ef23d96edd8cda76e30 (patch)
treea506a5dea5e6b3d8e766cf487412c73ec8eeb6df /recipes-core/systemd
parent05cc0d582c0d3a8a20b02b992589b151b2aad10a (diff)
layer: convert to new override syntax
This is the result of automated script (0.9.3) conversion: +# meta-toradex-distro +vars = vars + ["preempt-rt","tdx","upstream"] +# meta-toradex-* machines +vars = vars + ["apalis-","colibri-","verdin-","tegra124"] +# meta-freescale +vars = vars + ["imx","mx6","mx7","mx8","use-mainline-bsp","use-nxp-bsp"] ../openembedded-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-core/systemd')
-rw-r--r--recipes-core/systemd/systemd_%.bbappend8
-rw-r--r--recipes-core/systemd/timestamp-service.bb2
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index afbc6f8..802daa2 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,17 +1,17 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/systemd:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/systemd:"
SRC_URI += "file://rndis.network"
-PACKAGECONFIG_append = " networkd"
+PACKAGECONFIG:append = " networkd"
PACKAGECONFIG[acl] = "-Dacl=true,-Dacl=false,acl"
-do_install_append() {
+do_install:append() {
# The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...
install -d ${D}${prefix}/lib/systemd/network/
install -m 0644 ${WORKDIR}/rndis.network ${D}${prefix}/lib/systemd/network/
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${nonarch_base_libdir}/systemd/network \
"
diff --git a/recipes-core/systemd/timestamp-service.bb b/recipes-core/systemd/timestamp-service.bb
index 24d4a1d..914e610 100644
--- a/recipes-core/systemd/timestamp-service.bb
+++ b/recipes-core/systemd/timestamp-service.bb
@@ -18,4 +18,4 @@ do_install () {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "timestamp.service"
+SYSTEMD_SERVICE:${PN} = "timestamp.service"