summaryrefslogtreecommitdiff
path: root/recipes-graphics/wayland-app-launch/wayland-app-launch.inc
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-29 20:05:35 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-29 20:05:35 +0200
commitbe5b0af7fa7fa341363e0ccfe0c7f8a85213d37f (patch)
treef4ce1d362df034210608c39e9206f3b68ee0e0a7 /recipes-graphics/wayland-app-launch/wayland-app-launch.inc
parentc8aea6d76d570377053854ca4f722395236aa095 (diff)
wayland-app-launch: add a simple systemd service
This tries to start a wayland application after weston got started. Create a copy of wayland-terminal-launch_1.0.bb with the variables changed according to your needs. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/wayland-app-launch/wayland-app-launch.inc')
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-app-launch.inc29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-graphics/wayland-app-launch/wayland-app-launch.inc b/recipes-graphics/wayland-app-launch/wayland-app-launch.inc
new file mode 100644
index 0000000..20a6c25
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-app-launch.inc
@@ -0,0 +1,29 @@
+SUMMARY = "Wayland application autostart"
+DESCRIPTION = "This will start a wayland application after the wayland socket has been created."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit allarch systemd
+
+RDEPENDS_${PN} += "weston-init ${INITIAL_APP_PKGS}"
+
+S = "${WORKDIR}"
+
+SRC_URI = " \
+ file://wayland-app-launch.service \
+ file://wayland-app-launch.sh.in \
+"
+FILESEXTRAPATHS_prepend := "${THISDIR}/wayland-app-launch:"
+
+do_compile () {
+ sed -e "s:@@wayland-application@@:${WAYLAND_APPLICATION}:" wayland-app-launch.sh.in > wayland-app-launch.sh
+}
+
+do_install () {
+ install -d ${D}/${bindir} ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/wayland-app-launch.service ${D}${systemd_unitdir}/system
+ install -m 0755 ${S}/wayland-app-launch.sh ${D}/${bindir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "wayland-app-launch.service"