summaryrefslogtreecommitdiff
path: root/qt5-layer
diff options
context:
space:
mode:
Diffstat (limited to 'qt5-layer')
-rw-r--r--qt5-layer/recipes-qt/qedit/files/0001-Options.cpp-provide-default-for-SIDE_PANEL_TOOLBAR_T.patch33
-rw-r--r--qt5-layer/recipes-qt/qedit/files/qedit.desktop9
-rw-r--r--qt5-layer/recipes-qt/qedit/qedit_2.8.2.bb33
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb24
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init43
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service10
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh2
7 files changed, 0 insertions, 154 deletions
diff --git a/qt5-layer/recipes-qt/qedit/files/0001-Options.cpp-provide-default-for-SIDE_PANEL_TOOLBAR_T.patch b/qt5-layer/recipes-qt/qedit/files/0001-Options.cpp-provide-default-for-SIDE_PANEL_TOOLBAR_T.patch
deleted file mode 100644
index 7c7f563..0000000
--- a/qt5-layer/recipes-qt/qedit/files/0001-Options.cpp-provide-default-for-SIDE_PANEL_TOOLBAR_T.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 0c9e80df71bde69179edcb6847eb381eeec5cf7c Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Tue, 26 Dec 2017 20:05:37 +0100
-Subject: [PATCH] Options.cpp: provide default for
- SIDE_PANEL_TOOLBAR_TEXT_POSITION
-
-prevents the following:
-
-| # qedit
-| 2017/12/26 17:24:23 Options::_find - invalid option: SIDE_PANEL_TOOLBAR_TEXT_POSITION
-| Segmentation fault (core dumped)
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- base/Options.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/base/Options.cpp b/base/Options.cpp
-index 2fb2c9f..cd099c6 100644
---- a/base/Options.cpp
-+++ b/base/Options.cpp
-@@ -62,6 +62,8 @@ void Options::installDefaultOptions()
- set( "FIXED_FONT_NAME", "Sans Serif,10" );
- set( "FONT_NAME", "Monospace,10" );
-
-+ set<int>( "SIDE_PANEL_TOOLBAR_TEXT_POSITION", 0 );
-+
- // toolbars default configuration
- set<int>( "TOOLBUTTON_ICON_SIZE", 0 );
- set<int>( "TOOLBUTTON_TEXT_POSITION", -1 );
---
-2.13.6
-
diff --git a/qt5-layer/recipes-qt/qedit/files/qedit.desktop b/qt5-layer/recipes-qt/qedit/files/qedit.desktop
deleted file mode 100644
index 14f5669..0000000
--- a/qt5-layer/recipes-qt/qedit/files/qedit.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=QEdit
-Comment=A Qt Text editor
-Exec=qedit %F
-Terminal=false
-Type=Application
-MimeType=text/plain;
-Icon=qedit
-Categories=Utility;TextEditor;Qt; \ No newline at end of file
diff --git a/qt5-layer/recipes-qt/qedit/qedit_2.8.2.bb b/qt5-layer/recipes-qt/qedit/qedit_2.8.2.bb
deleted file mode 100644
index 11bb90d..0000000
--- a/qt5-layer/recipes-qt/qedit/qedit_2.8.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "QEdit Text Editor"
-HOMEPAGE = "http://hugo.pereira.free.fr/software/index.php?page=package&package_list=software_list_qt&package=qedit&full=0"
-SECTION = "x11"
-
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://COPYING;md5=81bcece21748c91ba9992349a91ec11d"
-
-DEPENDS = "qtbase qtx11extras"
-
-inherit cmake_qt5
-
-SRC_URI = " \
- http://hugo.pereira.free.fr/software/tgz/qedit-2.8.2.tar.gz \
- file://qedit.desktop \
- file://0001-Options.cpp-provide-default-for-SIDE_PANEL_TOOLBAR_T.patch \
-"
-SRC_URI[md5sum] = "7cca177ea042b230678ba0bb36269665"
-SRC_URI[sha256sum] = "cc0686927ec8ffe44527f682b3a8d9585f753d643543fae061cb023a3b71ddb0"
-
-EXTRA_OECMAKE = "-DUSE_QT5=ON"
-#export EXTRA_OECMAKE = "-DCMAKE_INSTALL_PREFIX=/usr"
-do_configure() {
- # Ensure we get the cmake configure and not qmake
- cmake_do_configure
-}
-
-do_install:append () {
- install -d ${D}/${datadir}/applications
- install -m 755 ${WORKDIR}/qedit.desktop ${D}/${datadir}/applications/
-}
-
-FILES:${PN} += ""
-FILES:${PN}-dev += ""
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
deleted file mode 100644
index 81769ff..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SECTION = "x11/libs"
-SUMMARY = "systemd qtapplication autostart"
-# The license is meant for this recipe and the files it installs.
-# RNDIS is part of the kernel, udhcpd is part of busybox
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-inherit allarch systemd
-
-SRC_URI = " \
- file://qt5-x11-demo.service \
- file://qt5-x11-demo-init \
-"
-
-do_install () {
- install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/qt5-x11-demo-init ${D}/${bindir}
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/qt5-x11-demo.service ${D}${systemd_unitdir}/system
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "qt5-x11-demo.service"
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init
deleted file mode 100644
index 76922ec..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-
-set -e
-
-cd /usr/share/qtsmarthome-1.0
-QTAPP="smarthome"
-QTAPPSTART="./${QTAPP} > /var/log/Xsession.log 2>&1"
-
-case "$1" in
- start)
- echo "Starting ${QTAPP}"
- if [ -f /etc/profile.d/tslib.sh ]; then
- source /etc/profile.d/tslib.sh
- fi
- if [ -e "$TSLIB_TSDEVICE" ]; then
- if [ ! -f /etc/pointercal ]; then
- /usr/bin/ts_calibrate
- fi
- else
- if [ -e "/usr/bin/xinput_calibrator_once.sh" ]; then
- xinput_calibrator_once.sh
- fi
- fi
- Xorg &
- export DISPLAY=:0
- eval $QTAPPSTART &
- ;;
- stop)
- echo "Stopping ${QTAPP}"
- killall $QTAPP
- killall Xorg
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 { start | stop | restart }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service
deleted file mode 100644
index 053f273..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=start X and a qt application
-
-[Service]
-Type=forking
-ExecStart=/usr/bin/qt5-x11-demo-init start
-ExecStop=/usr/bin/qt5-x11-demo-init stop
-
-[Install]
-WantedBy=graphical.target
diff --git a/qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh b/qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh
deleted file mode 100644
index 8bbd73b..0000000
--- a/qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-export QT_QPA_PLATFORM=xcb