summaryrefslogtreecommitdiff
path: root/recipes-connectivity/connman
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/connman')
-rw-r--r--recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch41
-rw-r--r--recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch29
-rw-r--r--recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch33
-rw-r--r--recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch28
-rw-r--r--recipes-connectivity/connman/connman_%.bbappend10
5 files changed, 75 insertions, 66 deletions
diff --git a/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch b/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch
new file mode 100644
index 0000000..91949a2
--- /dev/null
+++ b/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch
@@ -0,0 +1,41 @@
+From 0d23846576b53b6a2a8391a29d44e82bf3aed588 Mon Sep 17 00:00:00 2001
+From: Ming Liu <ming.liu@toradex.com>
+Date: Tue, 28 Dec 2021 13:50:13 +0100
+Subject: [PATCH] Adjust main configuration
+
+- Blacklist rndis nic's, we want them handled by systemd's networkd.
+- Disable background scan, to avoid significant increase in bandwidth.
+
+Upstream-Status: Inappropriate [Toradex specific]
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+Signed-off-by: Ming Liu <ming.liu@toradex.com>
+---
+ src/main.conf | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/main.conf b/src/main.conf
+index 14965e1..24a17bf 100644
+--- a/src/main.conf
++++ b/src/main.conf
+@@ -23,7 +23,7 @@
+ # When BackgroundScanning is false, ConnMan will not perform any scan
+ # regardless of wifi is connected or not, unless it is requested by
+ # the user through a D-Bus call.
+-# BackgroundScanning = true
++BackgroundScanning = false
+
+ # Assume that service gateways also function as timeservers.
+ # UseGatewaysAsTimeservers = false
+@@ -67,7 +67,7 @@
+ # not be handled by ConnMan, if their first characters
+ # match any of the list entries. Default value is
+ # vmnet,vboxnet,virbr,ifb,ve-,vb-.
+-# NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-
++NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-,usb,rndis
+
+ # Allow ConnMan to change the system hostname. This can
+ # happen for example if we receive DHCP hostname option.
+--
+2.25.1
+
diff --git a/recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch b/recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch
new file mode 100644
index 0000000..0f8bc47
--- /dev/null
+++ b/recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch
@@ -0,0 +1,29 @@
+From fcf27214f779478b449ea5ffe6d915fd6057cade Mon Sep 17 00:00:00 2001
+From: Igor Opaniuk <igor.opaniuk@toradex.com>
+Date: Mon, 30 Nov 2020 15:17:30 +0200
+Subject: [PATCH] connman: clock: ntp client should not update time/timezone
+
+NTP client should not update time/timezone unless otherwise stated
+explicitly in the settings.
+
+Upstream-Status: Inappropriate [configuration]
+Signed-off-by: Igor Opaniuk <igor.opaniuk@toradex.com>
+---
+ src/clock.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/clock.c b/src/clock.c
+index 0fde2c3..c9a26c6 100644
+--- a/src/clock.c
++++ b/src/clock.c
+@@ -35,8 +35,8 @@ enum timezone_updates {
+ TIMEZONE_UPDATES_AUTO = 2,
+ };
+
+-static enum time_updates time_updates_config = TIME_UPDATES_AUTO;
+-static enum timezone_updates timezone_updates_config = TIMEZONE_UPDATES_AUTO;
++static enum time_updates time_updates_config = TIME_UPDATES_MANUAL;
++static enum timezone_updates timezone_updates_config = TIME_UPDATES_MANUAL;
+
+ static char *timezone_config = NULL;
+
diff --git a/recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch b/recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch
deleted file mode 100644
index 65da8ff..0000000
--- a/recipes-connectivity/connman/connman/0001-connman.service.in-don-t-start-if-nfs-boot.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 390493e5aab8a6c859a9d14020b6b9cd09bf6f57 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Fri, 30 Dec 2016 13:43:52 +0100
-Subject: [PATCH] connman.service.in: don't start if nfs boot
-
-connman reconnects its NIC's. If doing a NFS boot the rootfs
-connection drops and the boot will fail.
-As a simple workaround do not manage the network with connman
-at all.
-Alternatively one could black list the network interface used
-for NFS in /etc/connman/main.conf.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- src/connman.service.in | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/connman.service.in b/src/connman.service.in
-index dab48bc..72c0c91 100644
---- a/src/connman.service.in
-+++ b/src/connman.service.in
-@@ -7,6 +7,8 @@ After=dbus.service network-pre.target systemd-sysusers.service
- Before=network.target multi-user.target shutdown.target
- Wants=network.target
- Conflicts=systemd-resolved.service
-+# only if not NFS mount, connman will disconnect your rootfs otherwise!
-+ConditionKernelCommandLine=!root=/dev/nfs
-
- [Service]
- Type=dbus
---
-2.12.0
-
diff --git a/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch b/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch
deleted file mode 100644
index dd6bafa..0000000
--- a/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 38a7afa59f0edc1e4c6a49e778e6456f6cd30446 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Fri, 30 Dec 2016 13:41:47 +0100
-Subject: [PATCH 2/2] main.conf: blacklist rndis nic's
-
-We want them handled by systemd's networkd.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- src/main.conf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/main.conf b/src/main.conf
-index 14965e1..d7b2951 100644
---- a/src/main.conf
-+++ b/src/main.conf
-@@ -67,7 +67,7 @@
- # not be handled by ConnMan, if their first characters
- # match any of the list entries. Default value is
- # vmnet,vboxnet,virbr,ifb,ve-,vb-.
--# NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-
-+NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-,usb,rndis
-
- # Allow ConnMan to change the system hostname. This can
- # happen for example if we receive DHCP hostname option.
---
-2.13.6
-
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend
index d90d435..683a023 100644
--- a/recipes-connectivity/connman/connman_%.bbappend
+++ b/recipes-connectivity/connman/connman_%.bbappend
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/connman:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/connman:"
-SRC_URI += " \
- file://0001-connman.service.in-don-t-start-if-nfs-boot.patch \
- file://0002-main.conf-blacklist-rndis-nic-s.patch \
+SRC_URI:append = " \
+ file://0001-Adjust-main-configuration.patch \
+ file://0001-connman-clock-ntp-client-should-not-update-time-time.patch \
"
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/connman/
install -m 0644 ${S}/src/main.conf ${D}${sysconfdir}/connman/
}