summaryrefslogtreecommitdiff
path: root/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--recipes-core/systemd/systemd_%.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 802daa2..e6cb9bc 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -2,6 +2,8 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/systemd:"
SRC_URI += "file://rndis.network"
+OURFILEPATH = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
PACKAGECONFIG:append = " networkd"
PACKAGECONFIG[acl] = "-Dacl=true,-Dacl=false,acl"
@@ -9,7 +11,7 @@ PACKAGECONFIG[acl] = "-Dacl=true,-Dacl=false,acl"
do_install:append() {
# The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...
install -d ${D}${prefix}/lib/systemd/network/
- install -m 0644 ${WORKDIR}/rndis.network ${D}${prefix}/lib/systemd/network/
+ install -m 0644 ${OURFILEPATH}/rndis.network ${D}${prefix}/lib/systemd/network/
}
FILES:${PN} += " \