summaryrefslogtreecommitdiff
path: root/recipes-core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd')
-rw-r--r--recipes-core/systemd/systemd_%.bbappend8
-rw-r--r--recipes-core/systemd/timestamp-service.bb2
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index afbc6f8..802daa2 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -1,17 +1,17 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/systemd:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/systemd:"
SRC_URI += "file://rndis.network"
-PACKAGECONFIG_append = " networkd"
+PACKAGECONFIG:append = " networkd"
PACKAGECONFIG[acl] = "-Dacl=true,-Dacl=false,acl"
-do_install_append() {
+do_install:append() {
# The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...
install -d ${D}${prefix}/lib/systemd/network/
install -m 0644 ${WORKDIR}/rndis.network ${D}${prefix}/lib/systemd/network/
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${nonarch_base_libdir}/systemd/network \
"
diff --git a/recipes-core/systemd/timestamp-service.bb b/recipes-core/systemd/timestamp-service.bb
index 24d4a1d..914e610 100644
--- a/recipes-core/systemd/timestamp-service.bb
+++ b/recipes-core/systemd/timestamp-service.bb
@@ -18,4 +18,4 @@ do_install () {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "timestamp.service"
+SYSTEMD_SERVICE:${PN} = "timestamp.service"