summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Schenker <philippe.schenker@toradex.com>2021-09-07 09:55:46 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-10-11 17:54:51 +0200
commiteccbaef9878f012395196e41ea38d10dd67001e6 (patch)
tree95a094a5a2ab2c2535b7e2d1c976ae140ac76727
parent7874c743a18d92e8bda948f0033a8cdc53b8995e (diff)
scripts: uprev-srcrev: add tezi
Relates-to: ELB-4127 Signed-off-by: Philippe Schenker <philippe.schenker@toradex.com> (cherry picked from commit e73336f9ff769414c5090640b6f33dc7b3169afb)
-rwxr-xr-xscripts/uprev-srcrev7
1 files changed, 7 insertions, 0 deletions
diff --git a/scripts/uprev-srcrev b/scripts/uprev-srcrev
index 7f93aad..ec17195 100755
--- a/scripts/uprev-srcrev
+++ b/scripts/uprev-srcrev
@@ -32,6 +32,11 @@ recipes:tdxref = [
"../layers/meta-toradex-tegra/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb",
]
+recipes_tezi = [
+ "../layers/meta-toradex-tezi/recipes-tezi/qt-tezi/qt-tezi_git.bb",
+ "../layers/meta-toradex-tezi/recipes-tezi/qt-tezi/qt-tezictl_git.bb",
+ ]
+
recipes_torizon = [
"../layers/meta-toradex-bsp-common/recipes-kernel/backports/backports_5.4.bb",
"../layers/meta-toradex-bsp-common/recipes-kernel/linux/linux-toradex-mainline_5.4.bb",
@@ -69,6 +74,8 @@ def uprev(args):
# decide if we build torizon or tdxref. Use the existence of meta-toradex-torizon
if os.path.exists(os.path.join(script_path, '../../meta-toradex-torizon')):
recipes = recipes_torizon
+ elif os.path.exists(os.path.join(script_path, '../../meta-toradex-tezi')):
+ recipes = recipes_tezi
else:
recipes = recipes:tdxref