summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoao Paulo Goncalves <joao.goncalves@toradex.com>2023-10-05 08:20:17 -0300
committerMax Krummenacher <max.krummenacher@toradex.com>2023-11-30 00:36:11 +0100
commit94a211cd865ebac70e5dda31501632fa61755cd4 (patch)
treebdcfc34618dc5f1aef55f00f76804acd28cacd09
parent8fc3277ebadeaeb75e1f54f007ddb2087dcf2132 (diff)
u-boot: Add dtb deploy by configuration
To support multiple boot containers on imx8 modules and also device-tree environment for different u-boot configurations, there is a need to deploy the dtb by configuration. The old method of deploying is not removed for backward compatibility when using only one u-boot configuration. Related-to: TEI-1113 Signed-off-by: Joao Paulo Goncalves <joao.goncalves@toradex.com> (cherry picked from commit caf5fc6d51833f41de44f195848ecaa096965e27)
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.04.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
index 42b9f75..25bb5a5 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2022.04.bb
@@ -39,6 +39,7 @@ do_deploy:append:mx8m-generic-bsp() {
then
install -d ${DEPLOYDIR}/${BOOT_TOOLS}
install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
+ install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}/${UBOOT_DTB_NAME}-${type}
install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
fi
done