summaryrefslogtreecommitdiff
path: root/recipes-bsp/imx-atf
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-09-01 17:17:45 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-09-02 09:54:54 +0200
commitbc161beac9cf6adbb6fc09d51559e8de52384d67 (patch)
tree4befb75490d8f432fedf53624c281a99783e4400 /recipes-bsp/imx-atf
parent8024b3d79e731eb93ab7208f4796671e5e8df556 (diff)
imx_atf: use git.toradex.com
This allows to drop the patches applied on our internal fork. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/imx-atf')
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch41
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-plat-imx8mm-provide-uart-base-as-build-option.patch43
-rw-r--r--recipes-bsp/imx-atf/imx-atf_%.bbappend15
3 files changed, 6 insertions, 93 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch b/recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch
deleted file mode 100644
index 052aa3a..0000000
--- a/recipes-bsp/imx-atf/imx-atf/0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From a307f33f84b76871ac6879ce93d26525af3e5bd9 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Tue, 19 May 2020 20:32:59 +0200
-Subject: [PATCH] Revert "Add NXP's SoCs partition reboot support."
-
-This reverts commit 13a5c7ece5a13c636e52f22b45f592b72b6453d1.
-With commit 13a5c7ece5a1 the SCFW will execute a reboot of the AP
-partition as a reaction to a psci_system_reboot, e.g. because of
-a Linux reboot.
-
-This does only reset the SoC partly, i.e. only IP which will not affect
-other partitions. As a result on Apalis iMX8 USB HSIC comes up in a
-state were it does not recognize our USB3503 hub correctly.
-
-Refer to the SCFW doc file sc_fw_port.pdf for more info on the various
-sc_reboot*, sc_reset* functionalities.
-
-Upstream-Status: Inappropriate [configuration]
-
-Related-to: ELB-2702
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- plat/imx/common/imx8_psci.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plat/imx/common/imx8_psci.c b/plat/imx/common/imx8_psci.c
-index bf0b2f6b1..310f81c2e 100644
---- a/plat/imx/common/imx8_psci.c
-+++ b/plat/imx/common/imx8_psci.c
-@@ -21,7 +21,7 @@ void __dead2 imx_system_off(void)
-
- void __dead2 imx_system_reset(void)
- {
-- sc_pm_reboot(ipc_handle, SC_PM_RESET_TYPE_COLD);
-+ sc_pm_reset(ipc_handle, SC_PM_RESET_TYPE_BOARD);
- wfi();
- ERROR("system reset failed.\n");
- panic();
---
-2.20.1
-
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-plat-imx8mm-provide-uart-base-as-build-option.patch b/recipes-bsp/imx-atf/imx-atf/0001-plat-imx8mm-provide-uart-base-as-build-option.patch
deleted file mode 100644
index d28c219..0000000
--- a/recipes-bsp/imx-atf/imx-atf/0001-plat-imx8mm-provide-uart-base-as-build-option.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From bbfc87c96dec60dda19438b7d6ecd2a5f4431380 Mon Sep 17 00:00:00 2001
-From: Igor Opaniuk <igor.opaniuk@gmail.com>
-Date: Thu, 5 Mar 2020 22:10:41 +0200
-Subject: [PATCH 1/2] plat: imx8mm: provide uart base as build option
-
-Some boards (f.e. Verdin i.MX8M Mini) use different UART base address
-for serial debug output, so make this value configurable (as a
-build option).
-
-Signed-off-by: Igor Opaniuk <igor.opaniuk@gmail.com>
-Change-Id: I988492ccecbc3f64a5153b381c4a97b8a0181f52
-(cherry picked from commit 60a23af2e57931161169c2981bf19af3847c533c)
----
- plat/imx/imx8m/imx8mm/include/platform_def.h | 1 -
- plat/imx/imx8m/imx8mm/platform.mk | 3 +++
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/plat/imx/imx8m/imx8mm/include/platform_def.h b/plat/imx/imx8m/imx8mm/include/platform_def.h
-index 42b03613e..094818087 100644
---- a/plat/imx/imx8m/imx8mm/include/platform_def.h
-+++ b/plat/imx/imx8m/imx8mm/include/platform_def.h
-@@ -51,7 +51,6 @@
-
- #define HAB_RVT_BASE U(0x00000900) /* HAB_RVT for i.MX8MM */
-
--#define IMX_BOOT_UART_BASE U(0x30890000)
- #define IMX_BOOT_UART_CLK_IN_HZ 24000000 /* Select 24MHz oscillator */
-
- #define PLAT_CRASH_UART_BASE IMX_BOOT_UART_BASE
-diff --git a/plat/imx/imx8m/imx8mm/platform.mk b/plat/imx/imx8m/imx8mm/platform.mk
-index 600a3c449..51da5c0ed 100644
---- a/plat/imx/imx8m/imx8mm/platform.mk
-+++ b/plat/imx/imx8m/imx8mm/platform.mk
-@@ -66,3 +66,6 @@ $(eval $(call add_define,BL32_SIZE))
- ifeq (${SPD},trusty)
- BL31_CFLAGS += -DPLAT_XLAT_TABLES_DYNAMIC=1
- endif
-+
-+IMX_BOOT_UART_BASE ?= 0x30890000
-+$(eval $(call add_define,IMX_BOOT_UART_BASE))
---
-2.20.1
-
diff --git a/recipes-bsp/imx-atf/imx-atf_%.bbappend b/recipes-bsp/imx-atf/imx-atf_%.bbappend
index 33034dc..dc825bd 100644
--- a/recipes-bsp/imx-atf/imx-atf_%.bbappend
+++ b/recipes-bsp/imx-atf/imx-atf_%.bbappend
@@ -1,13 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI_append = " \
- file://0001-plat-imx8mm-provide-uart-base-as-build-option.patch \
- file://0001-Revert-Add-NXP-s-SoCs-partition-reboot-support.patch \
-"
-
PV = "2.2+git${SRCPV}"
-SRCBRANCH = "imx_5.4.24_2.1.0"
-SRCREV = "b0a00f22b09c13572d3e87902a1069dee34763bd"
+SRCBRANCH = "toradex_imx_5.4.24_2.1.0"
+SRCREV = "9f183affc0221dac69fa2599ac91b9abad2c4465"
+SRCREV_use-head-next = "${AUTOREV}"
+SRC_URI = "git://git.toradex.com/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
+ file://0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch \
+"
EXTRA_OEMAKE_append_verdin-imx8mm = " \
IMX_BOOT_UART_BASE=0x30860000 \