summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-12-02 15:05:46 +0000
committerStefan Agner <stefan.agner@toradex.com>2019-12-18 12:02:49 +0000
commitfb011a860a33abe2df59304adb6c7a5e9cf5573c (patch)
treebb537042b28cdcab515fbd72135f1e3486ef1437 /recipes-kernel
parentf8ebc80f28f4b12c1d502e7614087b5a1d49f60d (diff)
linux-toradex: use new versioning
Use toradex-kernel-localversion class to implement the new versioning scheme for U-Boot. Signed-off-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex_4.14-2.0.x.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-toradex_4.14-2.0.x.bb b/recipes-kernel/linux/linux-toradex_4.14-2.0.x.bb
index 76c534c..0cea902 100644
--- a/recipes-kernel/linux/linux-toradex_4.14-2.0.x.bb
+++ b/recipes-kernel/linux/linux-toradex_4.14-2.0.x.bb
@@ -11,7 +11,9 @@ SRC_URI = " \
# Load USB functions configurable through configfs (CONFIG_USB_CONFIGFS)
KERNEL_MODULE_AUTOLOAD += "${@bb.utils.contains('COMBINED_FEATURES', 'usbgadget', ' libcomposite', '',d)}"
-LOCALVERSION = "-${TDX_VER_ITEM}"
+inherit toradex-kernel-localversion
+# Make sure to override LOCALVERSION in linux-imx.inc
+LOCALVERSION = "-${TDX_VERSION}"
PV_append = "+git${SRCPV}"
SRCREV = "397564ae5691bd47180acbc12729777ee688041b"
@@ -21,6 +23,3 @@ SRCBRANCH_use-head-next = "toradex_4.14-2.0.x-imx-next"
DEPENDS += "lzop-native bc-native"
COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"
-
-# defaults
-TDX_VER_ITEM ??= "0"