summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2020-08-23 17:38:00 +0200
committerMing Liu <ming.liu@toradex.com>2020-08-23 17:49:51 +0200
commitfb9bd93e2bddb73570d5c6bca070a9c0298cd21c (patch)
treee0d97889b0a968b67f2f7c32c8883f86cebd2fed /recipes-kernel
parent2b85dbe743daac36743449cfedb3b188220f7a90 (diff)
linux-toradex: set KERNEL_FEATURES to empty
Now we are inheriting kernel-yocto.bbclass by including recipes-kernel/linux/linux-imx.inc, but we dont support KMETA build so we need explicitly reset KERNEL_FEATURES to empty, this prevents do_kernel_metadata to look for kernel feature configs in KMETA which will certainly fail. Related-to: TOR-1262 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
index fc22b5f..3b51cbb 100644
--- a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
+++ b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
@@ -1,6 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
require recipes-kernel/linux/linux-imx.inc
+python () {
+ # Explicitly set KERNEL_FEATURES to empty, since we dont support KMETA yet.
+ kernel_features = d.getVar('KERNEL_FEATURES')
+ if kernel_features:
+ d.setVar('KERNEL_FEATURES', '')
+}
+
SUMMARY = "Linux kernel for Toradex Freescale i.MX based modules"
SUMMARY_append_preempt-rt = "Real-Time Linux kernel for Toradex Freescale i.MX based modules"