summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2022-10-07 15:55:55 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-10-14 13:55:14 +0200
commit457264ed1381ac09ca0980340881360b433553f2 (patch)
tree13671675ae2111b21086b2b6e1c53b61b545e396 /recipes-support
parenta0f8867376480b8021412034fa33b62aa47f934f (diff)
btuart: fix overrides
Turns out that somehow we still have some old override syntax stuff laying around! This resulted in the following build error: ERROR: btuart-1.0-r0 do_package: QA Issue: btuart: Files/directories were installed but not shipped in any package: /usr /lib /usr/sbin /usr/sbin/btuart.sh /lib/systemd /lib/systemd/system /lib/systemd/system/btuart.service Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. btuart: 7 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Marcel Ziswiler <marcel.ziswiler@toradex.com> (cherry picked from commit 4155ae8d8eef233773c13749807c0b6c7c91a133)
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/btuart/btuart.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-support/btuart/btuart.bb b/recipes-support/btuart/btuart.bb
index 5cc4066..dabe9d4 100644
--- a/recipes-support/btuart/btuart.bb
+++ b/recipes-support/btuart/btuart.bb
@@ -4,7 +4,7 @@ LICENSE = "PD"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-RRECOMMENDS_${PN} = "bluez5"
+RRECOMMENDS:${PN} = "bluez5"
SRC_URI = " \
file://btuart.sh \
@@ -23,11 +23,11 @@ do_install () {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "btuart.service"
+SYSTEMD_SERVICE:${PN} = "btuart.service"
inherit allarch systemd
-pkg_postinst_ontarget_${PN}_verdin-imx8mp () {
+pkg_postinst_ontarget:${PN}:verdin-imx8mp () {
# only BT UART modules need our service
if fgrep -q V1.0 /proc/device-tree/toradex,board-rev || ! fgrep -q toradex,verdin-imx8mp-wifi /proc/device-tree/compatible; then
/bin/systemctl disable btuart.service