summaryrefslogtreecommitdiff
path: root/recipes-support
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 10:30:21 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2020-06-18 14:15:50 +0200
commit92dc91e1517830dd07771e4207ccef4a1a563153 (patch)
tree6423d017a36b1ab45524dbf360aafc886ce28352 /recipes-support
parent4951b7f09c1ef7e160bfa23e39bb6c61946213ec (diff)
bmode-usb: replace soc overrides to also include use-mainline-bsp
With use-mainline-bsp the SoC overrides mx6/mx6q/mx6ull... are filtered out of the overrides. Replace them with the specific machine name. Related-to: ELB-2805 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit aae172f7a1c11d45e7e52b7906f02c3366feaa53)
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/bmode-usb/bmode-usb_1.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-support/bmode-usb/bmode-usb_1.0.bb b/recipes-support/bmode-usb/bmode-usb_1.0.bb
index a6c14e0..752c09b 100644
--- a/recipes-support/bmode-usb/bmode-usb_1.0.bb
+++ b/recipes-support/bmode-usb/bmode-usb_1.0.bb
@@ -5,8 +5,9 @@ LIC_FILES_CHKSUM = "file://bmode_usb.c;endline=5;md5=4c9010cb42fb7648a460c35e6b5
SRC_URI = "file://bmode_usb.c"
S = "${WORKDIR}"
DEFINE = "NO_MACHINE"
-DEFINE_mx6 = "MX6"
-DEFINE_mx6ull = "MX6ULL"
+DEFINE_apalis-imx6 = "MX6"
+DEFINE_colibri-imx6 = "MX6"
+DEFINE_colibri-imx6ull = "MX6ULL"
do_compile() {
${CC} -o bmode_usb bmode_usb.c ${CFLAGS} ${LDFLAGS} -D ${DEFINE}