summaryrefslogtreecommitdiff
path: root/recipes-graphics/wayland/weston-init.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston-init.bbappend')
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
new file mode 100644
index 0000000..c92a3c6
--- /dev/null
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -0,0 +1,14 @@
+INI_UNCOMMENT_ASSIGNMENTS_append_mx8 = " \
+ use-g2d=1 \
+"
+
+
+uncomment() {
+ # already uncommented, do nothing
+ if ! (grep "^$1" $2); then
+ if ! (grep "^#$1" $2); then
+ bbfatal "Commented setting '#$1' not found in file $2"
+ fi
+ sed -i -e 's,^#'"$1"','"$1"',g' $2
+ fi
+}