summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb')
-rw-r--r--recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
index 06c3578..e8fcf95 100644
--- a/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
+++ b/recipes-kernel/linux/linux-toradex_5.4-2.1.x.bb
@@ -1,13 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
require recipes-kernel/linux/linux-imx.inc
-python () {
- # Explicitly set KERNEL_FEATURES to empty, since we dont support KMETA yet.
- kernel_features = d.getVar('KERNEL_FEATURES')
- if kernel_features:
- d.setVar('KERNEL_FEATURES', '')
-}
-
SUMMARY = "Linux kernel for Toradex Freescale i.MX based modules"
SUMMARY_append_preempt-rt = "Real-Time Linux kernel for Toradex Freescale i.MX based modules"
@@ -51,6 +44,7 @@ KBUILD_DEFCONFIG_mx8 ?= "defconfig"
MIRRORS_append_preempt-rt = "${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/older/ ${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/"
SRC_URI_append_preempt-rt = " \
${KERNELORG_MIRROR}/linux/kernel/projects/rt/5.4/older/patch-5.4.47-rt28.patch.xz;name=rt-patch \
+ file://preempt-rt.scc \
"
# This patches do currently not apply but are likely needed or we get
# runtime bugs.
@@ -60,12 +54,3 @@ SRC_URI_append_preempt-rt = " \
SRC_URI[rt-patch.md5sum] = "032a1eee60e746fe32a3aa73604bc3e4"
SRC_URI[rt-patch.sha256sum] = "dadc1379e816e8a23f09713884f8889f0177f291974487f33efc9a646082c562"
-
-kernel_do_configure_append_preempt-rt() {
- # switch to use PREEMPT_RT
- kernel_configure_variable PREEMPT_NONE n
- kernel_configure_variable PREEMPT_VOLUNTARY n
- kernel_configure_variable PREEMPT n
- kernel_configure_variable PREEMPT_RT y
- oe_runmake olddefconfig
-}