summaryrefslogtreecommitdiff
path: root/freertos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'freertos/CMakeLists.txt')
-rw-r--r--freertos/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/freertos/CMakeLists.txt b/freertos/CMakeLists.txt
new file mode 100644
index 0000000..23eb791
--- /dev/null
+++ b/freertos/CMakeLists.txt
@@ -0,0 +1,15 @@
+set(FREERTOS_HEAP_ALLOCATOR 4)
+
+list(APPEND SOURCES
+ ${CMAKE_CURRENT_LIST_DIR}/src/croutine.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/event_groups.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/list.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/queue.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/tasks.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/timers.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/port.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/fsl_tickless_systick.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/fsl_tickless_lptmr.c
+ # include the specified heap allocator
+ ${CMAKE_CURRENT_LIST_DIR}/src/portable/MemMang/heap_${FREERTOS_HEAP_ALLOCATOR}.c
+ )