summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-04-26 12:34:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-07 17:38:48 +0200
commit22eeed1472f82c33ac7a303e18b1b6623253542f (patch)
treeb97dba7497bef51a0a5ee463991ce873f6842b1c
parent2cadb9d00c74cabdf63caae464ac885b740079d9 (diff)
qt5: drop x11 as the graphical backend
Our X11 distros are unmaintained for a while now. Likely built images will not run if they even build. Drop them for BSP 7. Remove them to not create unmet expectation. Related-to: ELB-5740 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb24
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init43
-rw-r--r--qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service10
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh2
4 files changed, 0 insertions, 79 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
deleted file mode 100644
index 81769ff..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SECTION = "x11/libs"
-SUMMARY = "systemd qtapplication autostart"
-# The license is meant for this recipe and the files it installs.
-# RNDIS is part of the kernel, udhcpd is part of busybox
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-inherit allarch systemd
-
-SRC_URI = " \
- file://qt5-x11-demo.service \
- file://qt5-x11-demo-init \
-"
-
-do_install () {
- install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/qt5-x11-demo-init ${D}/${bindir}
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/qt5-x11-demo.service ${D}${systemd_unitdir}/system
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "qt5-x11-demo.service"
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init
deleted file mode 100644
index 76922ec..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo-init
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-
-set -e
-
-cd /usr/share/qtsmarthome-1.0
-QTAPP="smarthome"
-QTAPPSTART="./${QTAPP} > /var/log/Xsession.log 2>&1"
-
-case "$1" in
- start)
- echo "Starting ${QTAPP}"
- if [ -f /etc/profile.d/tslib.sh ]; then
- source /etc/profile.d/tslib.sh
- fi
- if [ -e "$TSLIB_TSDEVICE" ]; then
- if [ ! -f /etc/pointercal ]; then
- /usr/bin/ts_calibrate
- fi
- else
- if [ -e "/usr/bin/xinput_calibrator_once.sh" ]; then
- xinput_calibrator_once.sh
- fi
- fi
- Xorg &
- export DISPLAY=:0
- eval $QTAPPSTART &
- ;;
- stop)
- echo "Stopping ${QTAPP}"
- killall $QTAPP
- killall Xorg
- ;;
- restart)
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 { start | stop | restart }" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service b/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service
deleted file mode 100644
index 053f273..0000000
--- a/qt5-layer/recipes-qt/qt5/qt5-x11-free-systemd/qt5-x11-demo.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=start X and a qt application
-
-[Service]
-Type=forking
-ExecStart=/usr/bin/qt5-x11-demo-init start
-ExecStop=/usr/bin/qt5-x11-demo-init stop
-
-[Install]
-WantedBy=graphical.target
diff --git a/qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh b/qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh
deleted file mode 100644
index 8bbd73b..0000000
--- a/qt5-layer/recipes-qt/qt5/qtbase/qt5-x11.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-export QT_QPA_PLATFORM=xcb