summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiago De Franco <hiago.franco@toradex.com>2024-03-14 17:26:25 -0300
committerHiago De Franco <hiago.franco@toradex.com>2024-03-18 08:57:18 -0300
commitc13441ea5a22efd026c858440a4a6c97c80d94b9 (patch)
tree77e4cc542c1ccfe56626d921717d343f5728ee42
parent51ff7e4550e6b502c1a3adbf5c21d3a2206ab889 (diff)
media-files: Update recipe from version 1.2 to 1.3
This new version envolves the following changes: - Update the SRC_URI to a new server and to download media-files tarball version 1.3. - New tarball does not have any rootfs folders inside (before it was 'home/root/files'), so with that it doesn't hardcode any folder for root home. - Because of the last, updated the poky do_install function to deploy the media-files inside the $ROOT_HOME. - SHA's updated and md5 SHA removed, since this is no longer used. - Use the license file CC0-1.0 from inside the media-files tarball, instead of the common one. Related-to: ELB-5646 Signed-off-by: Hiago De Franco <hiago.franco@toradex.com>
-rw-r--r--recipes-multimedia/media-files/media-files_1.2.bb13
-rw-r--r--recipes-multimedia/media-files/media-files_1.3.bb28
2 files changed, 28 insertions, 13 deletions
diff --git a/recipes-multimedia/media-files/media-files_1.2.bb b/recipes-multimedia/media-files/media-files_1.2.bb
deleted file mode 100644
index 335518d..0000000
--- a/recipes-multimedia/media-files/media-files_1.2.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "Media Files for tests"
-LICENSE = "CC0-1.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/CC0-1.0;md5=0ceb3372c9595f0a8067e55da801e4a1"
-
-inherit allarch bin_package
-
-SRC_URI = " \
- https://developer1.toradex.com/files/toradex-dev/uploads/media/Colibri/AddSW/Linux/ReleaseTest/media-files-${PV}.tar.xz \
-"
-SRC_URI[md5sum] = "9db08fa5c08063d345a7fc7e8b49b55e"
-SRC_URI[sha256sum] = "f6f40cd90ba6da06644cbfe5d48498c42836654897707fedeaaea6e00d99d334"
-
-S = "${WORKDIR}/media-files"
diff --git a/recipes-multimedia/media-files/media-files_1.3.bb b/recipes-multimedia/media-files/media-files_1.3.bb
new file mode 100644
index 0000000..c51497f
--- /dev/null
+++ b/recipes-multimedia/media-files/media-files_1.3.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Media Files for tests"
+LICENSE = "CC0-1.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/CC0-1.0;md5=0ceb3372c9595f0a8067e55da801e4a1"
+
+inherit allarch bin_package
+
+SRC_URI = "https://docs1.toradex.com/114780-media-files-${PV}.tar.xz"
+
+SRC_URI[sha256sum] = "d6a3cd2003798fec80fb8008d2e48a5fa2c581f4ae66c03cd573d33b18341e67"
+
+S = "${WORKDIR}/media-files"
+
+# Install the files to ${D}${ROOT_HOME}
+# Source code of original poky function:
+# https://git.yoctoproject.org/poky/plain/meta/classes-recipe/bin_package.bbclass
+# The function is being modified to install it inside ROOT_HOME, since we want
+# these files inside the root directory and ROOT_HOME can change.
+do_install () {
+ # Do it carefully
+ [ -d "${S}" ] || exit 1
+ if [ -z "$(ls -A ${S})" ]; then
+ bbfatal bin_package has nothing to install. Be sure the SRC_URI unpacks into S.
+ fi
+ cd ${S}
+ install -d ${D}${base_prefix}${ROOT_HOME}
+ tar --no-same-owner --exclude='./patches' --exclude='./.pc' -cpf - . \
+ | tar --no-same-owner -xpf - -C ${D}${base_prefix}${ROOT_HOME}
+}