summaryrefslogtreecommitdiff
path: root/qt5-layer/recipes-qt/qt5
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 11:30:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 17:32:46 +0200
commit48fb6ae80a1aa5765ff420877219d8eb35b11396 (patch)
tree0e422642fa0d25006184f51dd9fc4b9f0b0c92b2 /qt5-layer/recipes-qt/qt5
parent9f699aed67850db573ee3c51de7110fd235084c1 (diff)
recipes: cope with moved directory for unpackHEADmaster
OE master (styhead) no longer unpacks in ${WORKDIR} but rather does it in path defined by the new variable UNPACKDIR. Additionally '${S} = ${WORKDIR}' is no longer allowed and results in a parse time error. Cope with the change so that the layer builds against scarthgap and styhead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'qt5-layer/recipes-qt/qt5')
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend4
1 files changed, 3 insertions, 1 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 83eeb1a..628516e 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -28,9 +28,11 @@ SRC_URI:append = " \
file://qt5-${IMX_BACKEND}.sh \
"
+OURFILEPATH = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
do_install:append () {
install -d ${D}${sysconfdir}/profile.d/
- install -m 0755 ${WORKDIR}/qt5-${IMX_BACKEND}.sh ${D}${sysconfdir}/profile.d/
+ install -m 0755 ${OURFILEPATH}/qt5-${IMX_BACKEND}.sh ${D}${sysconfdir}/profile.d/
}