summaryrefslogtreecommitdiff
path: root/recipes-connectivity/hostapd-example/hostapd-example.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-08-08 11:11:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2021-08-14 13:18:40 +0200
commite7f6f37cdbc8ba971a151ef23d96edd8cda76e30 (patch)
treea506a5dea5e6b3d8e766cf487412c73ec8eeb6df /recipes-connectivity/hostapd-example/hostapd-example.bb
parent05cc0d582c0d3a8a20b02b992589b151b2aad10a (diff)
layer: convert to new override syntax
This is the result of automated script (0.9.3) conversion: +# meta-toradex-distro +vars = vars + ["preempt-rt","tdx","upstream"] +# meta-toradex-* machines +vars = vars + ["apalis-","colibri-","verdin-","tegra124"] +# meta-freescale +vars = vars + ["imx","mx6","mx7","mx8","use-mainline-bsp","use-nxp-bsp"] ../openembedded-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-connectivity/hostapd-example/hostapd-example.bb')
-rw-r--r--recipes-connectivity/hostapd-example/hostapd-example.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-connectivity/hostapd-example/hostapd-example.bb b/recipes-connectivity/hostapd-example/hostapd-example.bb
index dc0b9db..17f52e8 100644
--- a/recipes-connectivity/hostapd-example/hostapd-example.bb
+++ b/recipes-connectivity/hostapd-example/hostapd-example.bb
@@ -2,9 +2,9 @@ SUMMARY = "Deployment of example files to run hostapd on Toradex demo images"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-RDEPENDS_${PN} = "hostapd"
+RDEPENDS:${PN} = "hostapd"
S = "${WORKDIR}"
@@ -17,8 +17,8 @@ SRC_URI = " \
inherit allarch systemd
-SYSTEMD_SERVICE_${PN} = "hostapd-example.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE:${PN} = "hostapd-example.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
do_install() {
install -d ${D}${systemd_unitdir}/system/ ${D}${systemd_unitdir}/network/ ${D}${sysconfdir}/
@@ -29,7 +29,7 @@ do_install() {
sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd-example.service
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${systemd_unitdir}/system/* \
${systemd_unitdir}/network/hostapd-example.network \
${sysconfdir}/hostapd-tdx-demo-img.conf \