summaryrefslogtreecommitdiff
path: root/recipes-core/base-files/base-files_3.0.14.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 11:30:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 17:32:46 +0200
commit48fb6ae80a1aa5765ff420877219d8eb35b11396 (patch)
tree0e422642fa0d25006184f51dd9fc4b9f0b0c92b2 /recipes-core/base-files/base-files_3.0.14.bbappend
parent9f699aed67850db573ee3c51de7110fd235084c1 (diff)
recipes: cope with moved directory for unpackHEADmaster
OE master (styhead) no longer unpacks in ${WORKDIR} but rather does it in path defined by the new variable UNPACKDIR. Additionally '${S} = ${WORKDIR}' is no longer allowed and results in a parse time error. Cope with the change so that the layer builds against scarthgap and styhead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-core/base-files/base-files_3.0.14.bbappend')
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
index f04619e..0b06e5b 100644
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -5,10 +5,12 @@ SRC_URI += " \
file://x11-display-var.sh \
"
+OURFILEPATH = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
do_install:append () {
install -m 0755 -d ${D}${sysconfdir}/profile.d
- install -m 0644 ${WORKDIR}/disable_systemd_coloroutput.sh ${D}${sysconfdir}/profile.d/
- install -m 0644 ${WORKDIR}/x11-display-var.sh ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${OURFILEPATH}/disable_systemd_coloroutput.sh ${D}${sysconfdir}/profile.d/
+ install -m 0644 ${OURFILEPATH}/x11-display-var.sh ${D}${sysconfdir}/profile.d/
# Make /media a symbolic link to /run/media
rmdir ${D}/media
ln -sf run/media ${D}/media