summaryrefslogtreecommitdiff
path: root/recipes-core/systemd
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 11:30:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-05-31 17:32:46 +0200
commit48fb6ae80a1aa5765ff420877219d8eb35b11396 (patch)
tree0e422642fa0d25006184f51dd9fc4b9f0b0c92b2 /recipes-core/systemd
parent9f699aed67850db573ee3c51de7110fd235084c1 (diff)
recipes: cope with moved directory for unpack
OE master (styhead) no longer unpacks in ${WORKDIR} but rather does it in path defined by the new variable UNPACKDIR. Additionally '${S} = ${WORKDIR}' is no longer allowed and results in a parse time error. Cope with the change so that the layer builds against scarthgap and styhead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-core/systemd')
-rw-r--r--recipes-core/systemd/systemd_%.bbappend4
-rw-r--r--recipes-core/systemd/timestamp-service.bb6
2 files changed, 7 insertions, 3 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index 802daa2..e6cb9bc 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -2,6 +2,8 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/systemd:"
SRC_URI += "file://rndis.network"
+OURFILEPATH = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
PACKAGECONFIG:append = " networkd"
PACKAGECONFIG[acl] = "-Dacl=true,-Dacl=false,acl"
@@ -9,7 +11,7 @@ PACKAGECONFIG[acl] = "-Dacl=true,-Dacl=false,acl"
do_install:append() {
# The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...
install -d ${D}${prefix}/lib/systemd/network/
- install -m 0644 ${WORKDIR}/rndis.network ${D}${prefix}/lib/systemd/network/
+ install -m 0644 ${OURFILEPATH}/rndis.network ${D}${prefix}/lib/systemd/network/
}
FILES:${PN} += " \
diff --git a/recipes-core/systemd/timestamp-service.bb b/recipes-core/systemd/timestamp-service.bb
index 914e610..676a153 100644
--- a/recipes-core/systemd/timestamp-service.bb
+++ b/recipes-core/systemd/timestamp-service.bb
@@ -8,13 +8,15 @@ SRC_URI = "file://timestamp.service \
file://load-timestamp.sh \
"
+S = "${@d.getVar("UNPACKDIR") or '${WORKDIR}'}"
+
do_install () {
install -d ${D}/${bindir}
- install -m 0755 ${WORKDIR}/load-timestamp.sh ${D}/${bindir}
+ install -m 0755 ${S}/load-timestamp.sh ${D}/${bindir}
install -d ${D}/${base_libdir}/systemd/system
- install -m 0644 ${WORKDIR}/timestamp.service ${D}/${base_libdir}/systemd/system/
+ install -m 0644 ${S}/timestamp.service ${D}/${base_libdir}/systemd/system/
}
SYSTEMD_PACKAGES = "${PN}"